summary refs log tree commit diff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-12-15 10:44:40 +0100
committerLars-Dominik Braun <lars@6xq.net>2021-12-16 08:58:06 +0100
commitc63b55d1283d9a4bfc5ecaf1cab01cd98a467b69 (patch)
treecba75a79cec0c0bdfc02237092f995e6aa081878 /gnu/packages/python-xyz.scm
parentdfb5f088cb0139a68f51f2db3d5a95adccc65999 (diff)
downloadguix-c63b55d1283d9a4bfc5ecaf1cab01cd98a467b69.tar.gz
gnu: Replace JUPYTER_CONFIG_DIR with JUPYTER_CONFIG_PATH.
Judging by the documentation
(https://jupyter.readthedocs.io/en/latest/use/jupyter-directories.html)
_DIR can only be a single value, whereas _PATH supports :-delimited
values and extends _DIR with extra directories.

* gnu/packages/python-xyz.scm (python-jupyter-core)[native-search-paths]:
Replace _DIR with _PATH.
(python-nbconvert)[arguments]: Unset JUPYTER_CONFIG_PATH during tests.
(python-notebook)[arguments]: Dito.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7f32fd2c48..5e26fe724f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8334,7 +8334,7 @@ without using the configuration machinery.")
     ;; search paths.
     (native-search-paths
      (list (search-path-specification
-            (variable "JUPYTER_CONFIG_DIR")
+            (variable "JUPYTER_CONFIG_PATH")
             (files '("etc/jupyter")))
            (search-path-specification
             (variable "JUPYTER_PATH")
@@ -11962,8 +11962,6 @@ time.")
              (when tests?
                ;; Some tests invoke the installed nbconvert binary.
                (add-installed-pythonpath inputs outputs)
-               ;; Tries to write to this path.
-               (unsetenv "JUPYTER_CONFIG_DIR")
                ;; Tests depend on templates installed to output.
                (setenv "JUPYTER_PATH"
                        (string-append
@@ -12082,6 +12080,8 @@ convert an @code{.ipynb} notebook file into various static formats including:
              (delete-file-recursively "notebook/tests/selenium")
              (when tests?
                (add-installed-pythonpath inputs outputs)
+               ;; Interferes with test expectations.
+               (unsetenv "JUPYTER_CONFIG_PATH")
                ;; Some tests do not expect all files to be installed in the
                ;; same directory, but JUPYTER_PATH contains multiple entries.
                (unsetenv "JUPYTER_PATH")