summary refs log tree commit diff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-01-19 15:05:07 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-01-19 23:55:43 +0100
commitd084e9d0368078223886c69377370a12cb8d1fd4 (patch)
tree2af8cdb6400573a81ea385303cbbdee554cff2d2 /gnu/packages/python-xyz.scm
parentd8c718d44c8d402e49982658c045bfb6dbb2c030 (diff)
downloadguix-d084e9d0368078223886c69377370a12cb8d1fd4.tar.gz
gnu: Add python-mediapy.
* gnu/packages/python-xyz.scm (python-mediapy): New variable.

Change-Id: I2e55c018670053c662ae2d896feefab3b505b139
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index aebbae1521..7f9955cffd 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4075,6 +4075,46 @@ lossless but can be tweaked for more aggressive cleaning.")
 after Andy Lester’s Perl module WWW::Mechanize.")
     (license license:bsd-3)))
 
+(define-public python-mediapy
+  (package
+    (name "python-mediapy")
+    (version "1.2.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/google/mediapy")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "14hmwib0dmy9h1w7allwsp0cgrfdv8f2sm9qlvy65yxai68v6vnl"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      #:phases
+      '(modify-phases %standard-phases
+         (add-after 'unpack 'fix-references
+           (lambda _
+             (substitute* "mediapy_test.py"
+               (("'/bin/bash")
+                (string-append "'" (which "bash")))))))))
+    (inputs (list ffmpeg-5))
+    (propagated-inputs (list python-absl-py
+                             python-ipython
+                             python-matplotlib
+                             python-numpy
+                             python-pillow))
+    (native-inputs
+     (list python-flit-core
+           python-pylint
+           python-pytest
+           python-pytest-xdist))
+    (home-page "https://github.com/google/mediapy")
+    (synopsis "Read/write/show images and videos in an IPython notebook")
+    (description "This Python library makes it easy to display images and
+videos in a notebook.")
+    (license license:asl2.0)))
+
 (define-public python-simpleaudio
   (package
     (name "python-simpleaudio")