summary refs log tree commit diff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-10-20 16:00:02 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-10-20 16:06:04 +0200
commitd2111894c48b2ebd7e7be683c07241bbd8a91919 (patch)
tree3d2a343ed3362970a1b1c19cf01fae9d74d4ebe2 /gnu/packages/python-xyz.scm
parentf4fa142276c958a75e90952824c6eefc3bad1056 (diff)
downloadguix-d2111894c48b2ebd7e7be683c07241bbd8a91919.tar.gz
gnu: Add python-portpicker.
* gnu/packages/python-xyz.scm (python-portpicker): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 732a548d99..0aac9a7228 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1289,6 +1289,31 @@ different units.")
 scatter plots, histograms and heatmaps in the terminal using braille dots.")
     (license license:expat)))
 
+(define-public python-portpicker
+  (package
+    (name "python-portpicker")
+    (version "1.6.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "portpicker" version))
+       (sha256
+        (base32 "1yiisk4h8qliwf99khz3lszrpjf6km76fbhzg01fwrbgz7b7yl5x"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      #:test-flags
+      ;; This fails because portserver ends up in bin, not site-packages
+      '(list "--ignore=src/tests/portserver_test.py")))
+    (propagated-inputs (list python-psutil))
+    (native-inputs (list python-pytest net-tools))
+    (home-page "https://github.com/google/python_portpicker")
+    (synopsis "Choose unique available network ports")
+    (description
+     "This package provides a library to choose unique available network
+ports.")
+    (license license:asl2.0)))
+
 (define-public python-mdx-gh-links
   (package
     (name "python-mdx-gh-links")