summary refs log tree commit diff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2024-01-13 11:30:08 +0100
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:44:26 +0200
commitdc26246ef6321a7a71daaa5f906f8e4965ecabec (patch)
tree8b2109d4b6bc4ddf2a3e43d941f4b03180554819 /gnu/packages/python-xyz.scm
parentef3bac711b9c7abd77b8d5bbcb1afa9db46589ce (diff)
downloadguix-dc26246ef6321a7a71daaa5f906f8e4965ecabec.tar.gz
gnu: python-pillow: Fix build with zlib 1.3.
* gnu/packages/patches/python-pillow-use-zlib-1.3.patch: New patch.
* gnu/local.mk (dist_patch_DATA): Register it.
* gnu/packages/python-xyz.scm (python-pillow): Use it.

Change-Id: I97e706c11f616c42fb604cb616a94663f389a376
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d88db26f00..1c20631cdb 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10249,7 +10249,9 @@ Python list with elements of type @code{PIL.Image} (from the
               (snippet '(begin
                           (delete-file-recursively "src/thirdparty")))
               (patches
-               (search-patches "python-pillow-CVE-2022-45199.patch"))))
+               (search-patches "python-pillow-CVE-2022-45199.patch"
+                               ;; Included in 10.1.0.
+                               "python-pillow-use-zlib-1.3.patch"))))
     (build-system python-build-system)
     (native-inputs (list python-pytest))
     (inputs (list freetype