summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorJan (janneke) Nieuwenhuizen <janneke@gnu.org>2020-04-13 07:47:38 +0200
committerJan Nieuwenhuizen <janneke@gnu.org>2020-04-19 16:18:00 +0200
commit189bfb555d1a5cac8d705588a0c7ccdeaafd6a99 (patch)
tree2b18c6971fe1125e266154b85d34bbdc1632f0f7 /gnu/packages/python.scm
parent0e907e27ed0066a0be56a7ace8a5fca6a36376eb (diff)
downloadguix-189bfb555d1a5cac8d705588a0c7ccdeaafd6a99.tar.gz
gnu: python: Build fix for the Hurd.
* gnu/packages/python.scm (python-2.7)[arguments]: Add `fix-regen'
stage to correct a reference to "/usr".
(python-3.8): Remove build fix for 2.x..3.5.9 that breaks on 3.8.2.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm14
1 files changed, 13 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index f0a6193a92..a30ad6fb6e 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -58,6 +58,7 @@
 ;;; Copyright © 2018 Luther Thompson <lutheroto@gmail.com>
 ;;; Copyright © 2018 Vagrant Cascadian <vagrant@debian.org>
 ;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
+;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -81,6 +82,7 @@
   #:use-module (gnu packages bash)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages dbm)
+  #:use-module (gnu packages hurd)
   #:use-module (gnu packages libffi)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages readline)
@@ -197,6 +199,14 @@
                                     "Lib/test/test_subprocess.py"))
                (("/bin/sh") (which "sh")))
              #t))
+          ,@(if (hurd-system?)
+                `((add-before 'build 'patch-regen-for-hurd
+                    (lambda* (#:key inputs #:allow-other-keys)
+                      (let ((libc (assoc-ref inputs "libc")))
+                        (substitute* "Lib/plat-generic/regen"
+                          (("/usr/include/") (string-append libc "/include/")))
+                        #t))))
+                '())
           (add-before 'configure 'do-not-record-configure-flags
             (lambda* (#:key configure-flags #:allow-other-keys)
               ;; Remove configure flags from the installed '_sysconfigdata.py'
@@ -383,7 +393,9 @@ data types.")
                 " test_socket")))
        ((#:phases phases)
        `(modify-phases ,phases
-
+          ,@(if (hurd-system?)
+                `((delete 'patch-regen-for-hurd)) ;regen was removed after 3.5.9
+                '())
           (add-before 'check 'set-TZDIR
             (lambda* (#:key inputs native-inputs #:allow-other-keys)
               ;; test_email requires the Olson time zone database.