summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2019-01-22 22:00:50 -0600
committerEric Bavier <bavier@member.fsf.org>2019-01-22 22:00:50 -0600
commit32922190977f701694880254a71feb2752222f94 (patch)
tree461d00366a5551f56088a2c40e2a3a01a3f70316 /gnu/packages/python.scm
parent85e457946917004cf1ae4f01ea2d51e028884333 (diff)
downloadguix-32922190977f701694880254a71feb2752222f94.tar.gz
gnu: python2: Fix test flags.
Reverts a9883939977f5fb0bd62d1dccb1ab0a772a4b720 in favor of a cleaner
approach.

* gnu/packages/python.scm (python-2.7)[arguments]: 'EXTRATESTOPTS' ->
'TESTOPTS'.  This overrides the default '-l' argument for memory leak checks
which is not compatible with the -j for parallelism.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm12
1 files changed, 2 insertions, 10 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index e8706ff688..4dfc95d301 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3,7 +3,7 @@
 ;;; Copyright © 2013, 2014, 2015, 2016, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2013, 2014, 2015, 2016 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2014, 2017 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2014, 2017, 2019 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2014, 2015 Federico Beffa <beffa@fbengineering.ch>
 ;;; Copyright © 2015 Omar Radwan <toxemicsquire4@gmail.com>
 ;;; Copyright © 2015 Pierre-Antoine Rault <par@rigelk.eu>
@@ -194,20 +194,12 @@
                             (assoc-ref %outputs "out") "/lib"))
        ;; With no -j argument tests use all available cpus, so provide one.
        #:make-flags
-       (list (format #f "EXTRATESTOPTS=-j~d" (parallel-job-count)))
+       (list (format #f "TESTOPTS=-j~d" (parallel-job-count)))
 
         #:modules ((ice-9 ftw) (ice-9 match)
                    (guix build utils) (guix build gnu-build-system))
         #:phases
         (modify-phases %standard-phases
-          (add-after 'unpack 'remove-findleaks-from-testopts
-            (lambda _
-              (substitute* "Makefile.pre.in"
-                ;; -l which is short for --findleaks isn't compatible with the
-                ;; -j flag added through the #:make-flags, therefore remove
-                ;; it. This only affects python-2.7.
-                (("TESTOPTS=	-l ") "TESTOPTS= "))
-              #t))
           (add-before
            'configure 'patch-lib-shells
            (lambda _