summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2017-10-17 09:59:35 +0200
committerRoel Janssen <roel@gnu.org>2017-10-17 09:59:35 +0200
commit357ab93aacbd882a48cd7961ab301afa78c941d0 (patch)
treee7afd1356251879f683c39bd140b4afe38c46d32 /gnu/packages/python.scm
parent4640a11bee7935e2063afda600afb747dc0f4e0b (diff)
downloadguix-357ab93aacbd882a48cd7961ab301afa78c941d0.tar.gz
gnu: Add python2-py2neo.
* gnu/packages/python.scm (python2-py2neo): New variable.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 68951d6bb3..46df5eaca8 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -7570,6 +7570,27 @@ to the database using Neo4j's binary protocol.  It aims to be minimal, while
 being idiomatic to Python.")
     (license license:asl2.0)))
 
+(define-public python2-py2neo
+  (package
+    (name "python2-py2neo")
+    (version "3.1.2")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "py2neo" version))
+              (sha256
+               (base32
+                "1f1q95vqcvlc3nsc33p841swnjdcjazddlq2dzi3qfnjqjrajxw1"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:python ,python-2))
+    (home-page "http://py2neo.org")
+    (synopsis "Library and toolkit for working with Neo4j in Python")
+    (description "This package provides a client library and toolkit for
+working with Neo4j from within Python applications and from the command
+line.  The core library has no external dependencies and has been carefully
+designed to be easy and intuitive to use.")
+    (license license:asl2.0)))
+
 (define-public python-wrapt
   (package
     (name "python-wrapt")