summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-01-02 16:07:56 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-02 16:33:57 +0100
commit493e5e6daa058b7eb5e2ffbeccad2a5bd47dc60d (patch)
tree2cc9a03a49529786c48a65b0a6a25d33e1b77c37 /gnu/packages/python.scm
parent4fc112b452b6ac086bd93efc2ba137990a44d34a (diff)
downloadguix-493e5e6daa058b7eb5e2ffbeccad2a5bd47dc60d.tar.gz
gnu: python-jupyter-console: Fix inputs.
* gnu/packages/python.scm (python-jupyter-console)[propagated-inputs]: Remove
python-ipython; replace python-prompt-toolkit with python-prompt-toolkit-1.
[native-inputs]: Add python-nose.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 1c5b163041..e15f6f6a8e 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -7279,14 +7279,15 @@ in the data.")
         (base32
          "1kam1qzgwr7srhm5r6aj90di5sws4bq0jmiw15452ddamb9yspal"))))
     (build-system python-build-system)
-    ;; FIXME: it's not clear how to run the tests.
+    ;; Tests only run in an TTY.
     (arguments `(#:tests? #f))
     (propagated-inputs
      `(("python-ipykernel" ,python-ipykernel)
-       ("python-ipython" ,python-ipython)
        ("python-jupyter-client" ,python-jupyter-client)
-       ("python-prompt-toolkit" ,python-prompt-toolkit)
+       ("python-prompt-toolkit" ,python-prompt-toolkit-1)
        ("python-pygments" ,python-pygments)))
+    (native-inputs
+     `(("python-nose" ,python-nose)))
     (home-page "https://jupyter.org")
     (synopsis "Jupyter terminal console")
     (description "This package provides a terminal-based console frontend for