summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorJan (janneke) Nieuwenhuizen <janneke@gnu.org>2020-10-26 14:14:01 +0100
committerJan (janneke) Nieuwenhuizen <janneke@gnu.org>2020-10-26 15:39:40 +0100
commit5319f716cf575321bef4c501d7aebdc7220d69cf (patch)
tree06bd990ee6589491fd3651fc4d497f61de1223d1 /gnu/packages/python.scm
parentb2dc7cb8f91d904e4d9530de84c3a846e5262e80 (diff)
downloadguix-5319f716cf575321bef4c501d7aebdc7220d69cf.tar.gz
gnu: python: Move Hurd-specific configure fix into a patch.
* gnu/packages/patches/python-3-configure-hurd.patch: this New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/python.scm (python-3.8)[source]: Use it.
[arguments]: Remove "support-hurd-cross-compile" stage.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm14
1 files changed, 2 insertions, 12 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 3414ad959b..62494bea20 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -373,7 +373,8 @@ data types.")
                         "python-3-fix-tests.patch"
                         "python-3.8-fix-tests.patch"
                         "python-3-deterministic-build-info.patch"
-                        "python-3-search-paths.patch"))
+                        "python-3-search-paths.patch"
+                        "python-3-hurd-configure.patch"))
               (sha256
                (base32
                 "1c43dbv9lvlp3ynqmgdi4rh8q94swanhqarqrdx62zmigpakw073"))
@@ -401,17 +402,6 @@ data types.")
           ,@(if (hurd-system?)
                 `((delete 'patch-regen-for-hurd)) ;regen was removed after 3.5.9
                 '())
-          ,@(if (hurd-target?)
-                ;; The build system refuses to cross-compile for unknown targets
-                ;; even though it works fine.  Add GNU/Hurd target.
-                ;; TODO: Make it a patch in a future rebuild cycle.
-                '((add-before 'configure 'support-hurd-cross-compile
-                    (lambda _
-                      (substitute* "configure"
-                        (("\\*-\\*-vxworks.*" all)
-                         (string-append "*-*-gnu)\nac_sys_system=GNU\n;;\n" all)))
-                      #t)))
-                '())
           (add-before 'check 'set-TZDIR
             (lambda* (#:key inputs native-inputs #:allow-other-keys)
               ;; test_email requires the Olson time zone database.