summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-11-01 13:20:38 +0100
committerRicardo Wurmus <rekado@elephly.net>2016-11-04 11:32:35 +0100
commit55436048d8aea6eb287c90ca4879304b5998724f (patch)
tree2c20c36a296ecd7eb188acb0a3ed8dfbba89d6f2 /gnu/packages/python.scm
parent2d321bb2c572ca91830da2790aa6883e6218b42a (diff)
downloadguix-55436048d8aea6eb287c90ca4879304b5998724f.tar.gz
gnu: Add python-bleach.
* gnu/packages/python.scm (python-bleach, python2-bleach): New
variables.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 28b38cfae6..8987450d5b 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6693,6 +6693,32 @@ Jupyter Notebook format and Python APIs for working with notebooks.")
 (define-public python2-nbformat
   (package-with-python2 python-nbformat))
 
+(define-public python-bleach
+  (package
+    (name "python-bleach")
+    (version "1.4.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "bleach" version))
+       (sha256
+        (base32
+         "0jvg3jxrvnx7xmm9gj262v60ib452xlnwlb0navyp7jsvcd0d4qj"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-html5lib" ,python-html5lib-0.9)
+       ("python-setuptools" ,python-setuptools)
+       ("python-six" ,python-six)))
+    (native-inputs
+     `(("python-nose" ,python-nose)))
+    (home-page "http://github.com/jsocol/bleach")
+    (synopsis "Whitelist-based HTML-sanitizing tool")
+    (description "Bleach is an easy whitelist-based HTML-sanitizing tool.")
+    (license license:asl2.0)))
+
+(define-public python2-bleach
+  (package-with-python2 python-bleach))
+
 (define-public python-chardet
   (package
     (name "python-chardet")