summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2014-09-05 10:01:13 -0400
committerDavid Thompson <dthompson2@worcester.edu>2014-09-05 23:31:20 -0400
commit8176d4d55bb05972101373076c5ff7e4085e1c95 (patch)
tree696bc5a3a5a658ef2fa9a3e901747faf759fda3b /gnu/packages/python.scm
parent5731cae394767b7f0fd60afdfe722af625083caf (diff)
downloadguix-8176d4d55bb05972101373076c5ff7e4085e1c95.tar.gz
gnu: Add python-markupsafe.
* gnu/packages/python.scm (python-markupsafe, python2-markupsafe): New
  variables.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index a4e9014e4d..ab6e5ac275 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1696,3 +1696,29 @@ environments and back.")
 
 (define-public python2-virtualenv
   (package-with-python2 python-virtualenv))
+
+(define-public python-markupsafe
+  (package
+    (name "python-markupsafe")
+    (version "0.23")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://pypi.python.org/packages/source/M/MarkupSafe/MarkupSafe-"
+             version ".tar.gz"))
+       (sha256
+        (base32
+         "1hvip33wva3fnmvfp9x5klqri7hpl1hkgqmjbss18nmrb7zimv54"))))
+    (build-system python-build-system)
+    (inputs
+     `(("python-setuptools" ,python-setuptools)))
+    (home-page "http://github.com/mitsuhiko/markupsafe")
+    (synopsis "XML/HTML/XHTML markup safe string implementation for Python")
+    (description
+     "Markupsafe provides an XML/HTML/XHTML markup safe string implementation
+for Python.")
+    (license bsd-3)))
+
+(define-public python2-markupsafe
+  (package-with-python2 python-markupsafe))