summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-04-21 14:25:05 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-04-21 15:36:36 +0200
commit833df99d625af91a52bcfc39d2f135f03dd51b37 (patch)
treeffa25ffa6ce4c7a24c2cb3f5db4cc8fb291f5711 /gnu/packages/python.scm
parenta7d12a9e71bfffce5d4a3e1106ec97a070d33da7 (diff)
downloadguix-833df99d625af91a52bcfc39d2f135f03dd51b37.tar.gz
gnu: python-pyopenssl: Update to 17.0.0.
* gnu/packages/python.scm (python-pyopenssl, python2-pyopenssl): Update to 17.0.0.
[native-inputs]: Change PYTHON-PYTEST to PYTHON-PYTEST-3.0.
* gnu/packages/patches/python-pyopenssl-skip-network-test.patch: Adjust.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index aa014db364..e51405bd9c 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -7323,14 +7323,14 @@ message digests and key derivation functions.")
 (define-public python-pyopenssl
   (package
     (name "python-pyopenssl")
-    (version "16.2.0")
+    (version "17.0.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "pyOpenSSL" version))
        (sha256
         (base32
-         "0vji4yrfshs15xpczbhzhasnjrwcarsqg87n98ixnyafnyxs6ybp"))
+         "1pdg1gpmkzj8yasg6cmkhcivxcdp4c12nif88y4qvsxq5ffzxas8"))
        (patches
         (search-patches "python-pyopenssl-skip-network-test.patch"))))
     (build-system python-build-system)
@@ -7348,7 +7348,7 @@ message digests and key derivation functions.")
     (inputs
      `(("openssl" ,openssl)))
     (native-inputs
-     `(("python-pytest" ,python-pytest)))
+     `(("python-pytest" ,python-pytest-3.0)))
     (home-page "https://github.com/pyca/pyopenssl")
     (synopsis "Python wrapper module around the OpenSSL library")
     (description