summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2014-09-03 08:06:29 -0400
committerDavid Thompson <dthompson2@worcester.edu>2014-09-05 23:31:20 -0400
commit864b5211cdb4688f3be66975dba4e753e2e59241 (patch)
treea9794af5e3827c9a2f6308ddcf7cb9663b9d447d /gnu/packages/python.scm
parente6cfbd364a16e372b036cba73c0f94e9c24933c6 (diff)
downloadguix-864b5211cdb4688f3be66975dba4e753e2e59241.tar.gz
gnu: Add python-jsonschema.
* gnu/packages/python.scm (python-jsonschema, python2-jsonschema): New
  variables.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 5562ed1a28..3ef862dd63 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1074,3 +1074,28 @@ is used by the Requests library to verify HTTPS requests.")
      "Requests is a Python HTTP client library.  It aims to be easier to use
 than Python’s urllib2 library.")
     (license asl2.0)))
+
+(define-public python-jsonschema
+  (package
+    (name "python-jsonschema")
+    (version "2.4.0")
+    (source (origin
+             (method url-fetch)
+             (uri
+              (string-append
+               "https://pypi.python.org/packages/source/j/jsonschema/jsonschema-"
+               version ".tar.gz"))
+             (sha256
+              (base32
+               "1yik3031ziygvq66rj3mzfqdgxj29sg1bkfc46wsgi7lnbqs560j"))))
+    (build-system python-build-system)
+    (inputs
+     `(("python-setuptools" ,python-setuptools)))
+    (home-page "http://github.com/Julian/jsonschema")
+    (synopsis "Implementation of JSON Schema for Python")
+    (description
+     "Jsonschema is an implementation of JSON Schema for Python.")
+    (license expat)))
+
+(define-public python2-jsonschema
+  (package-with-python2 python-jsonschema))