summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-10-13 13:29:49 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-10-13 16:35:48 +0200
commitdd86c0d10c4b95f44fafc00a01174601cbaf7b9b (patch)
treec0bcdb26f75553931c3a77b75ccf654ec4f37efb /gnu/packages/python.scm
parent331a1cd727c1bb5aa6f9cd7f0a52c21d3c5c159f (diff)
downloadguix-dd86c0d10c4b95f44fafc00a01174601cbaf7b9b.tar.gz
gnu: python-scipy, python2-scipy: Propagate Python inputs.
* gnu/packages/python.scm (python-scipy)[inputs]: Move "python-numpy",
  "python-matplotlib", and "python-pyparsing" to propagated-inputs; move
  "python-nose" and "python-sphinx" to native-inputs.
  [propagated-inputs]: New field.
  [native-inputs]: Move "python-nose" and "python-sphinx" from inputs
  field here.
  (python2-scipy): Modify propagated-inputs instead of inputs field.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm24
1 files changed, 13 insertions, 11 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index fc4fad6f98..5a2c14eb4f 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3261,16 +3261,17 @@ functions.")
         (base32
          "0fsqi05s035d7p6s8h3h2pvk1axias16chy17rw9l1bxvrfhmncf"))))
     (build-system python-build-system)
-    (inputs
+    (propagated-inputs
      `(("python-numpy" ,python-numpy)
        ("python-matplotlib" ,python-matplotlib)
-       ("python-pyparsing" ,python-pyparsing)
-       ("python-nose" ,python-nose)
-       ("python-sphinx" ,python-sphinx)
-       ("lapack" ,lapack)
+       ("python-pyparsing" ,python-pyparsing)))
+    (inputs
+     `(("lapack" ,lapack)
        ("openblas" ,openblas)))
     (native-inputs
-     `(("gfortran" ,gfortran)
+     `(("python-nose" ,python-nose)
+       ("python-sphinx" ,python-sphinx)
+       ("gfortran" ,gfortran)
        ("texlive" ,texlive)
        ("perl" ,perl)))
     (outputs '("out" "doc"))
@@ -3339,11 +3340,12 @@ routines such as routines for numerical integration and optimization.")
   (let ((scipy (package-with-python2 python-scipy)))
     (package (inherit scipy)
       ;; Use packages customized for python-2.
-      (inputs `(("python2-matplotlib" ,python2-matplotlib)
-                ("python2-numpy" ,python2-numpy)
-                ,@(alist-delete "python-matplotlib"
-                                (alist-delete "python-numpy"
-                                              (package-inputs scipy))))))))
+      (propagated-inputs
+       `(("python2-matplotlib" ,python2-matplotlib)
+         ("python2-numpy" ,python2-numpy)
+         ,@(alist-delete "python-matplotlib"
+                         (alist-delete "python-numpy"
+                                       (package-propagated-inputs scipy))))))))
 
 (define-public python-sqlalchemy
   (package