summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2017-10-05 11:56:45 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-10-05 12:04:32 +0200
commiteaa1db1de615bc0ed51b295a0a191ce2c816ee7e (patch)
tree3c80abaaeb40e0eed8db4e6e35208cda75c0f2b0 /gnu/packages/python.scm
parent46cf31868c1b12eec50bc9b8dda64604dd81f986 (diff)
downloadguix-eaa1db1de615bc0ed51b295a0a191ce2c816ee7e.tar.gz
Revert "gnu: python-numpy: Update to 1.13.1."
This reverts commit 025b196d9b739418dd9d305864fdb1fb1d0d5af2.

This is necessary as neither the current release nor the latest development
version of python-pandas can be build with numpy 1.13.x.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 5052b65022..271f147b43 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3720,21 +3720,22 @@ between language specification and implementation aspects.")
 (define-public python-numpy
   (package
     (name "python-numpy")
-    (version "1.13.1")
+    (version "1.12.0")
     (source
      (origin
        (method url-fetch)
-       (uri (pypi-uri "numpy" version ".zip"))
+       (uri (string-append
+             "https://github.com/numpy/numpy/archive/v" version ".tar.gz"))
+       (file-name (string-append name "-" version ".tar.gz"))
        (sha256
         (base32
-         "1fsgkhh1vdkhmlz8vmdgxnj9n9yaanckxxzz9s0b4p08fqvjic69"))))
+         "025d4j4aakcp8w5i5diqh812cbbjgac7jszx1j56ivrbi1i8vv7d"))))
     (build-system python-build-system)
     (inputs
      `(("openblas" ,openblas)
        ("lapack" ,lapack)))
     (native-inputs
-     `(("unzip" ,unzip)
-       ("python-cython" ,python-cython)
+     `(("python-cython" ,python-cython)
        ("python-nose" ,python-nose)
        ("gfortran" ,gfortran)))
     (arguments