summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-03-04 13:02:05 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-03-04 22:58:56 +0100
commited709ee954817486a5021b182b539dafa80549fb (patch)
treee7e195ded614809638e15a39cc8d743579e11b80 /gnu/packages/python.scm
parent4aeb42b9f88a9191cfa5f7fed75143e0a03488c2 (diff)
downloadguix-ed709ee954817486a5021b182b539dafa80549fb.tar.gz
gnu: Python@2: Update to 2.7.16.
* gnu/packages/patches/python2-CVE-2018-1000802.patch,
gnu/packages/patches/python2-CVE-2018-14647.patch: Delete files.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/python.scm (python-2.7): Update to 2.7.16.
[source](patches): Remove obsolete.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 9ed16d447e..0a483fb1db 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -94,7 +94,7 @@
 (define-public python-2.7
   (package
     (name "python2")
-    (version "2.7.15")
+    (version "2.7.16")
     (source
      (origin
       (method url-fetch)
@@ -102,14 +102,12 @@
                           version "/Python-" version ".tar.xz"))
       (sha256
        (base32
-        "0x2mvz9dp11wj7p5ccvmk9s0hzjk2fa1m462p395l4r6bfnb3n92"))
+        "1mqfcqp5y8r0bfyr7ppl74n0lig45p9mc4b8adlcpvj74rhfy8pj"))
       (patches (search-patches "python-2.7-search-paths.patch"
                                "python-2-deterministic-build-info.patch"
                                "python-2.7-site-prefixes.patch"
                                "python-2.7-source-date-epoch.patch"
-                               "python-2.7-adjust-tests.patch"
-                               "python2-CVE-2018-14647.patch"
-                               "python2-CVE-2018-1000802.patch"))
+                               "python-2.7-adjust-tests.patch"))
       (modules '((guix build utils)))
       ;; suboptimal to delete failing tests here, but if we delete them in the
       ;; arguments then we need to make sure to strip out that phase when it