summary refs log tree commit diff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-01-02 15:45:27 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-02 16:33:57 +0100
commitf0eb442c20466a256f1851522330baccb1afb287 (patch)
tree7fad9b121e1e1ec28a5204f63d84cce93827d983 /gnu/packages/python.scm
parent92a9f93615b14fe684c9670f8c103687c308cff8 (diff)
downloadguix-f0eb442c20466a256f1851522330baccb1afb287.tar.gz
gnu: python-ipykernel: Update to 5.1.0.
* gnu/packages/python.scm (python-ipykernel): Update to 5.1.0.
[arguments]: Enable tests.
[propagated-inputs]: Add python-ipython.
[native-inputs]: Add python-pytest and python-nose.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm23
1 files changed, 16 insertions, 7 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 56234b7559..ee51f2387c 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -4856,20 +4856,29 @@ installing @code{kernelspec}s for use with Jupyter frontends.")
 (define-public python-ipykernel
   (package
     (name "python-ipykernel")
-    (version "4.5.2")
+    (version "5.1.0")
     (source
      (origin
       (method url-fetch)
       (uri (pypi-uri "ipykernel" version))
       (sha256
-       (base32 "0qllv0k6zzv1r1cj1x2ygxmlrrqhbslzj8rc6r6fg3kc1rgz4m2s"))))
+       (base32 "0br95qhrd5k65g10djngiy27hs0642301hlf2q142i8djabvzh0g"))))
     (build-system python-build-system)
-    ;; The tests load a submodule of IPython.  However, IPython itself depends
-    ;; on ipykernel.
-    (arguments `(#:tests? #f))
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda _
+             (setenv "HOME" "/tmp")
+             (invoke "pytest" "-v")
+             #t)))))
     (propagated-inputs
-     ;; imported at runtime during connect
-     `(("python-jupyter-client" ,python-jupyter-client)))
+     `(("python-ipython" ,python-ipython)
+       ;; imported at runtime during connect
+       ("python-jupyter-client" ,python-jupyter-client)))
+    (native-inputs
+     `(("python-pytest" ,python-pytest)
+       ("python-nose" ,python-nose)))
     (home-page "https://ipython.org")
     (synopsis "IPython Kernel for Jupyter")
     (description