summary refs log tree commit diff
path: root/gnu/packages/qemu.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-08-16 06:03:53 -0500
committerEric Bavier <bavier@member.fsf.org>2015-08-16 18:06:25 -0500
commit20c263b00fc89355f423e64c7dd591c3ec438ef2 (patch)
tree8a4d4c9e15e4a047ce0fbddae4db89f4c3a3c19f /gnu/packages/qemu.scm
parent4e0143738fb0497b9d3c2a9a2426798e8f00f7ec (diff)
downloadguix-20c263b00fc89355f423e64c7dd591c3ec438ef2.tar.gz
gnu: qemu: Honor #:configure-flags argument.
* gnu/packages/qemu.scm (qemu-headless)[arguments]: Honor #:configure-flags
  arguments for configure phase.
Diffstat (limited to 'gnu/packages/qemu.scm')
-rw-r--r--gnu/packages/qemu.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/gnu/packages/qemu.scm b/gnu/packages/qemu.scm
index af39427f75..6979655122 100644
--- a/gnu/packages/qemu.scm
+++ b/gnu/packages/qemu.scm
@@ -74,7 +74,8 @@
     (arguments
      '(#:phases (alist-replace
                  'configure
-                 (lambda* (#:key inputs outputs #:allow-other-keys)
+                 (lambda* (#:key inputs outputs (configure-flags '())
+                           #:allow-other-keys)
                    ;; The `configure' script doesn't understand some of the
                    ;; GNU options.  Thus, add a new phase that's compatible.
                    (let ((out (assoc-ref outputs "out")))
@@ -87,11 +88,13 @@
                      ;; The binaries need to be linked against -lrt.
                      (setenv "LDFLAGS" "-lrt")
                      (zero?
-                      (system* "./configure"
-                               (string-append "--cc=" (which "gcc"))
+                      (apply system*
+                             `("./configure"
+                               ,(string-append "--cc=" (which "gcc"))
                                "--disable-debug-info" ; save build space
                                "--enable-virtfs"      ; just to be sure
-                               (string-append "--prefix=" out)))))
+                               ,(string-append "--prefix=" out)
+                               ,@configure-flags)))))
                  (alist-cons-after
                   'install 'install-info
                   (lambda* (#:key inputs outputs #:allow-other-keys)