summary refs log tree commit diff
path: root/gnu/packages/qemu.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-11-23 18:21:31 +0100
committerLudovic Courtès <ludo@gnu.org>2013-11-23 18:21:44 +0100
commit4942d42a94b8900cf622c802ce83be5e6e2bc1a0 (patch)
tree6156cabee42ea3fc09119bd3141e003e669662a6 /gnu/packages/qemu.scm
parent558a5122fad8a396190eed01f2230f86076d9238 (diff)
downloadguix-4942d42a94b8900cf622c802ce83be5e6e2bc1a0.tar.gz
gnu: qemu: Add GUI version.
* gnu/packages/qemu.scm (qemu): Rename to...
  (qemu-headless): ... this.
  (qemu/smb-shares): Inherit from it.
  (qemu): New variable.
* gnu/packages/grub.scm (qemu-for-tests): Inherit from QEMU-HEADLESS.
Diffstat (limited to 'gnu/packages/qemu.scm')
-rw-r--r--gnu/packages/qemu.scm26
1 files changed, 17 insertions, 9 deletions
diff --git a/gnu/packages/qemu.scm b/gnu/packages/qemu.scm
index 8efde67595..406d4d12af 100644
--- a/gnu/packages/qemu.scm
+++ b/gnu/packages/qemu.scm
@@ -36,12 +36,13 @@
   #:use-module (gnu packages linux)
   #:use-module (gnu packages samba)
   #:use-module (gnu packages xorg)
+  #:use-module (gnu packages sdl)
   #:use-module (gnu packages perl))
 
-(define-public qemu
-  ;; Since QEMU 1.3, it incorporates KVM support formerly found in QEMU-KVM.
+(define-public qemu-headless
+  ;; This is QEMU without GUI support.
   (package
-    (name "qemu")
+    (name "qemu-headless")
     (version "1.5.1")
     (source (origin
              (method url-fetch)
@@ -91,8 +92,7 @@
                   %standard-phases))))
 
     (inputs                                       ; TODO: Add optional inputs.
-     `(;; ("mesa" ,mesa)
-       ;; ("libaio" ,libaio)
+     `(;; ("libaio" ,libaio)
        ("glib" ,glib)
        ("python" ,python-2) ; incompatible with Python 3 according to error message
        ("ncurses" ,ncurses)
@@ -104,7 +104,6 @@
        ;; ("pciutils" ,pciutils)
        ("pkg-config" ,pkg-config)
        ("alsa-lib" ,alsa-lib)
-       ;; ("SDL" ,SDL)
        ("zlib" ,zlib)
        ("attr" ,attr)
        ("samba" ,samba)))                         ; an optional dependency
@@ -112,7 +111,7 @@
                      ("perl" ,perl)))
 
     (home-page "http://www.qemu-project.org")
-    (synopsis "Machine emulator and virtualizer")
+    (synopsis "Machine emulator and virtualizer (without GUI)")
     (description
      "QEMU is a generic machine emulator and virtualizer.
 
@@ -132,8 +131,17 @@ server and embedded PowerPC, and S390 guests.")
 (define-public qemu/smb-shares
   ;; A patched QEMU where `-net smb' yields two shares instead of one: one for
   ;; the store, and another one for exchanges with the host.
-  (package (inherit qemu)
+  (package (inherit qemu-headless)
     (name "qemu-with-multiple-smb-shares")
-    (source (origin (inherit (package-source qemu))
+    (source (origin (inherit (package-source qemu-headless))
               (patches
                (list (search-patch "qemu-multiple-smb-shares.patch")))))))
+
+(define-public qemu
+  ;; QEMU with GUI support.
+  (package (inherit qemu-headless)
+    (name "qemu")
+    (synopsis "Machine emulator and virtualizer")
+    (inputs `(("sdl" ,sdl)
+              ("mesa" ,mesa)
+              ,@(package-inputs qemu-headless)))))