summary refs log tree commit diff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-05-18 09:55:28 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-05-18 09:55:28 +0300
commit4e825e2da39fb484fccff8d86e75d1bc0a13a1e2 (patch)
tree6f19ce0fa7462b4185d50af913d114d8b7612e5e /gnu/packages/qt.scm
parent04f8decf1f8cea68bd05b29fd732b0508fcb9573 (diff)
downloadguix-4e825e2da39fb484fccff8d86e75d1bc0a13a1e2.tar.gz
gnu: qtbase: Update configure flags.
* gnu/packages/qt.scm (qtbase)[arguments]: Change the configure flags to
not use the precompiled headers. Enable x86_64 special hardware
instructions which have runtime detection.
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm12
1 files changed, 4 insertions, 8 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 46fbb03049..805675696d 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -468,19 +468,15 @@ developers using C++ or QML, a CSS & JavaScript like language.")
                        "-openssl-linked"
                        ;; explicitly link with dbus instead of dlopening it
                        "-dbus-linked"
-                       ;; drop special machine instructions not supported
-                       ;; on all instances of the target
+                       ;; don't use the precompiled headers
+                       "-no-pch"
+                       ;; drop special machine instructions that do not have
+                       ;; runtime detection
                        ,@(if (string-prefix? "x86_64"
                                              (or (%current-target-system)
                                                  (%current-system)))
                              '()
                              '("-no-sse2"))
-                       "-no-sse3"
-                       "-no-ssse3"
-                       "-no-sse4.1"
-                       "-no-sse4.2"
-                       "-no-avx"
-                       "-no-avx2"
                        "-no-mips_dsp"
                        "-no-mips_dspr2")))))
          (add-after 'install 'patch-qt_config.prf