summary refs log tree commit diff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2017-09-02 23:20:15 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2017-10-13 13:53:39 +0200
commit4eb972b95cbb9fa6c27283dd4b4ec9581838e85e (patch)
tree4bb166a9714390b50abe9829b74302e5c0431f4b /gnu/packages/qt.scm
parent163651cbdc7b28bb7417a4e45cf885e42b7f5af0 (diff)
downloadguix-4eb972b95cbb9fa6c27283dd4b4ec9581838e85e.tar.gz
gnu: qtwebkit: Fix rpath for the qmlwebkit plugins.
After the qtbase installation directories have been changed,
the relative RPATH in the libs no longer matched the sructure.

* gnu/packages/qt.scm(qtwebkit)[arguments]: New phase
  fix-qmlwebkit-plugins-rpath.
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 0f911dc783..4df2674fea 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1890,6 +1890,15 @@ different kinds of sliders, and much more.")
     (arguments
      `(#:phases
        (modify-phases %standard-phases
+         (add-before 'configure 'fix-qmlwebkit-plugins-rpath
+           (lambda _
+             (substitute* "Source/WebKit/qt/declarative/experimental/experimental.pri"
+               (("RPATHDIR_RELATIVE_TO_DESTDIR = \\.\\./\\.\\./lib")
+                "RPATHDIR_RELATIVE_TO_DESTDIR = ../../../../../lib"))
+             (substitute* "Source/WebKit/qt/declarative/public.pri"
+               (("RPATHDIR_RELATIVE_TO_DESTDIR = \\.\\./\\.\\./lib")
+                "RPATHDIR_RELATIVE_TO_DESTDIR = ../../../../lib"))
+             #t))
          (replace 'configure
                   (lambda* (#:key outputs #:allow-other-keys)
                     (let ((out (assoc-ref outputs "out")))