summary refs log tree commit diff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-07-16 17:11:03 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-07-16 17:11:03 +0200
commit86b995dcce534363ef56ae4335e402f77740ae24 (patch)
tree5faf662e9242f7d13d8451f58232ab7d7a96b54b /gnu/packages/qt.scm
parentd619686250d8bb15bf67031f8ac80f9cfb400a26 (diff)
downloadguix-86b995dcce534363ef56ae4335e402f77740ae24.tar.gz
gnu: Qt@4: Build with GCC 5 and OpenSSL 1.0.
* gnu/packages/qt.scm (qt-4)[inputs]: Replace OPENSSL with OPENSSL-1.0.
[native-inputs]: Add GCC-5.
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm13
1 files changed, 10 insertions, 3 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index afc4d8dc06..e5fc40b351 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -11,6 +11,7 @@
 ;;; Copyright © 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;; Copyright © 2018 Hartmut Goebel <h.goebel@crazy-compilers.com>
 ;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -46,6 +47,7 @@
   #:use-module (gnu packages fontutils)
   #:use-module (gnu packages flex)
   #:use-module (gnu packages freedesktop)
+  #:use-module (gnu packages gcc)
   #:use-module (gnu packages gl)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages gperf)
@@ -423,11 +425,16 @@ system, and the core design of Django is reused in Grantlee.")
     (inputs
      `(,@(fold alist-delete
                (package-inputs qt)
-               '("harfbuzz" "libjpeg"))
+               '("harfbuzz" "libjpeg" "openssl"))
        ("libjpeg" ,libjpeg-8)
-       ("libsm" ,libsm)))
+       ("libsm" ,libsm)
+       ("openssl" ,openssl-1.0)))
     (native-inputs
-     `(,@(fold alist-delete
+     `(;; XXX: The JavaScriptCore engine does not build with the C++11 standard.
+       ;; We could build it with -std=gnu++98, but then we'll get in trouble with
+       ;; ICU later.  Just keep using GCC 5 for now.
+       ("gcc" ,gcc-5)
+       ,@(fold alist-delete
                (package-native-inputs qt)
                '("vulkan-headers"))))