summary refs log tree commit diff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2014-11-20 23:52:48 +0100
committerAndreas Enge <andreas@enge.fr>2014-11-21 18:01:22 +0100
commitff53457d053ff697f88689818fd668b9ede715a9 (patch)
treeb87807d115168a6db51a3649eef1c20a1496f98b /gnu/packages/qt.scm
parentc736bc94e992e1a64f6c0593f00ec24d20cb0609 (diff)
downloadguix-ff53457d053ff697f88689818fd668b9ede715a9.tar.gz
gnu: libxkbcommon: Update to 0.5.0.
* gnu/packages/qt.scm (libxkbcommon): Update to 0.5.0.
    Add input libxcb and native input pkg-config.
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 92945cfe03..46c7c34c3c 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -42,17 +42,20 @@
 (define-public libxkbcommon
   (package
     (name "libxkbcommon")
-    (version "0.3.1")
+    (version "0.5.0")
     (source (origin
              (method url-fetch)
              (uri (string-append "http://xkbcommon.org/download/" name "-"
                                  version ".tar.xz"))
              (sha256
               (base32
-               "13mk335r4dhi9qglzbp46ina1wz4qgcp8r7s06iq7j50pf0kb5ww"))))
+               "176ii5dn2wh74q48sd8ac37ljlvgvp5f506glr96z6ibfhj7igch"))))
     (build-system gnu-build-system)
+    (inputs
+     `(("libxcb" ,libxcb)))
     (native-inputs
-     `(("bison" ,bison)))
+     `(("bison" ,bison)
+       ("pkg-config" ,pkg-config)))
     (home-page "http://xkbcommon.org/")
     (synopsis "Library to handle keyboard descriptions")
     (description "Xkbcommon is a library to handle keyboard descriptions,