summary refs log tree commit diff
path: root/gnu/packages/racket.scm
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2021-11-19 06:06:40 -0500
committerArun Isaac <arunisaac@systemreboot.net>2021-11-24 23:59:37 +0530
commit6de284e832fe6056aec7e89823c0be0a46682c39 (patch)
tree97a63aac22d1350ce9ba41c9a4a2fc9a9b62ecb3 /gnu/packages/racket.scm
parent3aac086c3f750b8d3aa793dbd9c72ec3212ab025 (diff)
downloadguix-6de284e832fe6056aec7e89823c0be0a46682c39.tar.gz
gnu: racket: Update to 8.3.
* gnu/packages/racket.scm (racket-minimal, racket): Update to 8.3.
* gnu/packages/racket.scm (racket-minimal)[source]: Remove
racket-minimal-backport-1629887.patch from patches.
* gnu/packages/patches/racket-minimal-backport-1629887.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Unregister it.

Signed-off-by: Arun Isaac <arunisaac@systemreboot.net>
Diffstat (limited to 'gnu/packages/racket.scm')
-rw-r--r--gnu/packages/racket.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/racket.scm b/gnu/packages/racket.scm
index 661443e0c3..5b142acdec 100644
--- a/gnu/packages/racket.scm
+++ b/gnu/packages/racket.scm
@@ -3,6 +3,7 @@
 ;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2020 Pierre Neidhardt <mail@ambrevar.xyz>
 ;;; Copyright © 2021 Philip McGrath <philip@philipmcgrath.com>
+;;; Copyright © 2021 jgart <jgart@dismail.de>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -128,7 +129,7 @@
 (define-public racket-minimal
   (package
     (name "racket-minimal")
-    (version "8.2")            ; note: remember to also update racket!
+    (version "8.3")            ; note: remember to also update racket!
     (source
      (origin
        (method git-fetch)
@@ -136,11 +137,9 @@
              (url "https://github.com/racket/racket")
              (commit (string-append "v" version))))
        (sha256
-        "061bhiyjlvazph0dj9i3i3x2q5z53rp8h5cjwg3frjimkr45lncn")
+        "1i1jnv1wb0kanfg47hniafx2vhwjc33qqx66lq7wkf5hbmgsyws3")
        (file-name (git-file-name name version))
-       (patches (search-patches "racket-minimal-sh-via-rktio.patch"
-                                ;; Remove the following in version 8.3:
-                                "racket-minimal-backport-1629887.patch"))
+       (patches (search-patches "racket-minimal-sh-via-rktio.patch"))
        (modules '((guix build utils)))
        (snippet
         (with-imported-modules '((guix build utils))
@@ -427,7 +426,7 @@ Chez Scheme.")
                  %installer-mirrors))
        (sha256
         (base32
-         "10sgzsraxzxp1k2y2wvz8rcjwvhbcd6k72l9lyqr34yazlwfdz26"))
+         "0jdr0y7scvv2a3sq456ifrgq0yfsbiwavdf2m86zmrapp481mby4"))
        (snippet
         #~(begin
             (use-modules (guix build utils)