summary refs log tree commit diff
path: root/gnu/packages/radio.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-01-27 20:08:19 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2021-01-27 22:33:06 +0100
commitaee72ed1c6ee75fb8fe8736e14596a429d023509 (patch)
tree1a20401b94d998457d6b1a1918e6395942ffaa8d /gnu/packages/radio.scm
parent6be6945251dd72d4558fd6babeb7f595b332ea41 (diff)
downloadguix-aee72ed1c6ee75fb8fe8736e14596a429d023509.tar.gz
gnu: Add qsstv.
* gnu/packages/radio.scm (qsstv): New variable.
Diffstat (limited to 'gnu/packages/radio.scm')
-rw-r--r--gnu/packages/radio.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index 95e86e560a..c3f1c0c933 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -66,6 +66,7 @@
   #:use-module (gnu packages tcl)
   #:use-module (gnu packages tex)
   #:use-module (gnu packages texinfo)
+  #:use-module (gnu packages video)
   #:use-module (gnu packages xml)
   #:use-module (gnu packages xorg)
   #:use-module (guix build-system cmake)
@@ -1147,3 +1148,43 @@ modes:
      "NanoVNA-Saver is a tool for reading, displaying and saving data from the
 NanoVNA vector network analyzers.")
     (license license:gpl3+)))
+
+(define-public qsstv
+  (package
+    (name "qsstv")
+    (version "9.4.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "http://users.telenet.be/on4qz/qsstv/downloads/"
+                           "qsstv_" version ".tar.gz"))
+       (sha256
+        (base32 "0f9hx6sy418cb23fadll298pqbc5l2lxsdivi4vgqbkvx7sw58zi"))))
+    (build-system qt-build-system)
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (inputs
+     `(("alsa-lib" ,alsa-lib)
+       ("fftw" ,fftw)
+       ("fftwf" ,fftwf)
+       ("hamlib" ,hamlib)
+       ("openjpeg" ,openjpeg)
+       ("pulseaudio" ,pulseaudio)
+       ("qtbase" ,qtbase)
+       ("v4l-utils" ,v4l-utils)))
+    (arguments
+     `(#:tests? #f  ; No test suite.
+       #:phases
+       (modify-phases %standard-phases
+         (replace 'configure
+           (lambda* (#:key outputs #:allow-other-keys)
+             (invoke "qmake"
+                     (string-append "PREFIX=" (assoc-ref outputs "out")))
+             #t)))))
+    (home-page "http://users.telenet.be/on4qz/qsstv/")
+    (synopsis "Program for receiving and transmitting SSTV and HAMDRM")
+    (description
+     "QSSTV is a program for receiving and transmitting SSTV and HAMDRM
+(sometimes called DSSTV).  It is compatible with most of MMSSTV and EasyPal.")
+    (license (list license:gpl2+
+                   license:qwt1.0))))