summary refs log tree commit diff
path: root/gnu/packages/robotics.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-10-20 21:53:50 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-10-21 00:26:14 +0200
commit7373eb8304e0ebbfabe66deb59e78187013403dd (patch)
treefa2d8a3b2731a85b9d2df2887280bcb22536a348 /gnu/packages/robotics.scm
parentbd1213708cb4d10b3a9bb633a2b21dc82f39f98b (diff)
downloadguix-7373eb8304e0ebbfabe66deb59e78187013403dd.tar.gz
gnu: protobuf: Update to 3.10.0.
* gnu/packages/protobuf.scm (protobuf, python-protobuf): Update to 3.10.0.
(protobuf-next, python-protobuf-next): Rename to ....
(protobuf-3.6, python-protobuf-3.6): ... this.
(protobuf-3.5): New public variable.
* gnu/packages/machine-learning.scm (grpc)[native-inputs]: Change from
PROTOBUF-NEXT to PROTOBUF.
(tensorflow)[native-inputs, propagated-inputs]: Adjust for renamed PROTOBUF-NEXT.
* gnu/packages/robotics.scm (aseba)[inputs]: Change from PROTOBUF to PROTOBUF-3.5.
* gnu/packages/telephony.scm (mumble)[inputs]: Likewise.
Diffstat (limited to 'gnu/packages/robotics.scm')
-rw-r--r--gnu/packages/robotics.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/robotics.scm b/gnu/packages/robotics.scm
index 389bb5a028..fbf10be366 100644
--- a/gnu/packages/robotics.scm
+++ b/gnu/packages/robotics.scm
@@ -106,7 +106,7 @@ hundred times faster than real-time.")
       (inputs
        `(("dashel" ,dashel)
          ("enki" ,enki)
-         ("protobuf" ,protobuf)                   ;for logging
+         ("protobuf" ,protobuf-3.5)               ;for logging
          ("qtbase" ,qtbase)
          ("qtsvg" ,qtsvg)
          ("qttools" ,qttools)              ;for libQt5Help, needed by "studio"