summary refs log tree commit diff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2023-07-23 18:38:06 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2024-02-24 16:42:40 +0100
commit10f72f90b35b126579462dcbe2cf23baf2bcc8d0 (patch)
tree46ba32ede865756d16dc8eef3b57a3d84be68855 /gnu/packages/ruby.scm
parent8bd01bb2d1a772f5975b2c666f54dae1b634d573 (diff)
downloadguix-10f72f90b35b126579462dcbe2cf23baf2bcc8d0.tar.gz
gnu: Add ruby-ipaddr.
* gnu/packages/ruby.scm (ruby-ipaddr): New variable.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 7b3312271d..6556c3a00c 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -4427,6 +4427,27 @@ help tests uncover more bugs.")
     (home-page "https://github.com/jordansissel/ruby-flores")
     (license license:asl2.0)))
 
+(define-public ruby-ipaddr
+  (package
+    (name "ruby-ipaddr")
+    (version "1.2.6")
+    (source (origin
+              (method git-fetch)  ;for tests
+              (uri (git-reference
+                    (url "https://github.com/ruby/ipaddr")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0h3z8i1fa8s4gx48322fflhpkzghd4bmd9109hglsgdkic7b0dyp"))))
+    (build-system ruby-build-system)
+    (native-inputs (list ruby-test-unit-ruby-core))
+    (synopsis "Manipulate IP addresses")
+    (description "This package provides a set of methods to manipulate an IP
+address.  Both IPv4 and IPv6 are supported.")
+    (home-page "https://github.com/ruby/ipaddr")
+    (license license:bsd-2)))
+
 (define-public ruby-net-http-persistent
   (package
     (name "ruby-net-http-persistent")