summary refs log tree commit diff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-08-26 17:03:59 +0200
committerJulien Lepiller <julien@lepiller.eu>2018-09-01 23:08:46 +0200
commit4ce0414bca13f609db27371a4f75c6e37111d10f (patch)
treee2367f4c7084c09e0401a66c8fe2744296462015 /gnu/packages/ruby.scm
parent5e2f74bdb847db3b4dd429efcacd6dd4432a771b (diff)
downloadguix-4ce0414bca13f609db27371a4f75c6e37111d10f.tar.gz
gnu: Add ruby-rouge.
* gnu/packages/ruby.scm (ruby-rouge): New variable.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 024a99ab4c..e605f3e6de 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5685,3 +5685,26 @@ parser for writing http servers, clients and proxies.")
     (description "Em-websocket is an EventMachine based WebSocket server
 implementation.")
     (license license:expat)))
+
+(define-public ruby-rouge
+  (package
+    (name "ruby-rouge")
+    (version "3.2.1")
+    (source (origin
+              (method url-fetch)
+              (uri (rubygems-uri "rouge" version))
+              (sha256
+               (base32
+                "0h79gn2wmn1wix2d27lgiaimccyj8gvizrllyym500pir408x62f"))))
+    (build-system ruby-build-system)
+    (arguments `(#:tests? #f)); No rakefile
+    (home-page "http://rouge.jneen.net/")
+    (synopsis "Code highlighter")
+    (description "Rouge is a code highlighter written in Ruby.  It supports more
+than 100 languages and outputs HTML or ANSI 256-color text.  Its HTML output
+is compatible with stylesheets designed for pygments.")
+    (license (list
+               ;; rouge is licensed under expat
+               license:expat
+               ;; pygments is licensed under bsd-2
+               license:bsd-2))))