summary refs log tree commit diff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorStephen Paul Weber <singpolyma@singpolyma.net>2022-07-02 12:00:24 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2022-07-02 12:01:41 -0400
commitb01043a8ceea39abd1d03b6479b4b218e719ef42 (patch)
tree8f251b4e03f0f943fba907ccd8f03fc4e43b4274 /gnu/packages/ruby.scm
parentd633207a7069fcc44d41dc008009cfb5408169c0 (diff)
downloadguix-b01043a8ceea39abd1d03b6479b4b218e719ef42.tar.gz
gnu: Add ruby-blather.
* gnu/packages/ruby.scm (ruby-blather): New variable.

Signed-off-by: Raghav Gururajan <rg@raghavgururajan.name>
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 24f2b49dec..c1e3dca807 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -12952,3 +12952,35 @@ integrate Braintree's global payments platform.")
    (description "Niceogiri provides wrappers and helpers for XML manipulation
 using Nokogiri.")
    (license license:expat)))
+
+(define-public ruby-blather
+  (package
+    (name "ruby-blather")
+    (version "2.0.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (rubygems-uri "blather" version))
+        (sha256
+          (base32 "05ry2x835fj4pzk61282pcz86n018cr39zbgwbi213md74i90s7c"))))
+    (build-system ruby-build-system)
+    (arguments
+     ;; XXX: Tests require too old version of rspec.
+     `(#:tests? #f))
+    (native-inputs
+     (list ruby-countdownlatch
+            ruby-mocha
+            ruby-rb-fsevent
+            ruby-rspec
+            ruby-yard))
+    (propagated-inputs
+     (list ruby-activesupport
+            ruby-eventmachine
+            ruby-niceogiri
+            ruby-nokogiri
+            ruby-sucker-punch))
+    (home-page "https://github.com/adhearsion/blather")
+    (synopsis "XMPP Domain Specific Language for Ruby")
+    (description "Blather is a XMPP DSL for Ruby written on top of EventMachine
+and Nokogiri.")
+    (license license:expat)))