summary refs log tree commit diff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-14 21:39:00 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-14 23:37:05 -0400
commitcfe4a07775fc542b431bdf0d94788b85088ff8c4 (patch)
tree6985aab36974a64b33672871d20de77ae92b6a59 /gnu/packages/ruby.scm
parent97e37a8a79d8f430f3023ebec49277b9cb65468a (diff)
downloadguix-cfe4a07775fc542b431bdf0d94788b85088ff8c4.tar.gz
gnu: ruby-tzinfo-data: Remove #:guile argument in file-union call.
* gnu/packages/ruby.scm (ruby-tzinfo-data) [arguments]: Strip trailing #t.
[native-inputs]: Remove #:guile argument in file-union call.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm15
1 files changed, 3 insertions, 12 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index feb78731c2..1dcd5f76a5 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7038,8 +7038,7 @@ aware transformations between times in different time zones.")
            (lambda* (#:key inputs #:allow-other-keys)
              (substitute* "Rakefile"
                (("https://data.iana.org/time-zones/releases")
-                (assoc-ref inputs "tzdata")))
-             #t))
+                (assoc-ref inputs "tzdata")))))
          (add-before 'check 'pre-check
            (lambda _
              (setenv "HOME" (getcwd))
@@ -7049,8 +7048,7 @@ aware transformations between times in different time zones.")
                (("    sh\\(\\\"make -C" text)
                 (string-append "    sh(\"sed -i 's@/bin/sh@sh@' #{tzdb_combined_path}/Makefile \")\n"
                                "    sh(\"sed -i 's@cc=@cc?=@' #{tzdb_combined_path}/Makefile \")\n" text)))
-               (setenv "cc" ,(cc-for-target))
-             #t)))))
+               (setenv "cc" ,(cc-for-target)))))))
     (propagated-inputs
      (list ruby-tzinfo))
     (native-inputs
@@ -7083,14 +7081,7 @@ aware transformations between times in different time zones.")
                  (uri "https://data.iana.org/time-zones/releases/tzcode2021a.tar.gz.asc")
                  (sha256
                   (base32
-                   "1qhlj4lr810s47s1lwcvv1sgvg2sflf98w4sbg1lc8wzv5qxxv7g")))))
-
-           ;; XXX: Explicitly depend on 'guile-final', which was previously
-           ;; implied via the '%guile-for-build' fluid but not explicit.
-           ;; TODO: Remove this argument on the next rebuild cycle.
-           #:guile (module-ref (resolve-interface
-                                '(gnu packages commencement))
-                               'guile-final)))))
+                   "1qhlj4lr810s47s1lwcvv1sgvg2sflf98w4sbg1lc8wzv5qxxv7g")))))))))
     (synopsis "Data from the IANA Time Zone database")
     (description
      "This library provides @code{TZInfo::Data}, which contains data from the