summary refs log tree commit diff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-17 22:06:10 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-28 22:22:43 -0400
commitd2b8af9b827d6a67ff999a5f672ba190dfa97e44 (patch)
treed6d95d1778fbb8be68e4ebc0f12325de549d523a /gnu/packages/ruby.scm
parent05d00e585efe55665f5daed068724ad4eef1cf65 (diff)
downloadguix-d2b8af9b827d6a67ff999a5f672ba190dfa97e44.tar.gz
gnu: ruby-shoulda-context: Honor #:tests?.
* gnu/packages/ruby.scm (ruby-shoulda-context)
[arguments]: Honor #:tests? in check phase.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 100df594e7..e2093161d7 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -10091,10 +10091,11 @@ engine.")
      `(#:phases
        (modify-phases %standard-phases
          (replace 'check
-           (lambda _
-             ;; Do not run tests to avoid circular dependence with rails.
-             ;; Instead just import the library to test.
-             (invoke "ruby" "-Ilib" "-r" "shoulda-context"))))))
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               ;; Do not run tests to avoid circular dependence with rails.
+               ;; Instead just import the library to test.
+               (invoke "ruby" "-Ilib" "-r" "shoulda-context")))))))
     (synopsis "Test::Unit context framework extracted from Shoulda")
     (description
      "@code{shoulda-context} is the context framework extracted from Shoulda.