summary refs log tree commit diff
path: root/gnu/packages/rust.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-01-10 08:38:40 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:57:41 +0200
commitf9a12c1e0275f94b64e459c2796410645a069d53 (patch)
treed31c78b0fa547cc1bcafb040464642b6248499ed /gnu/packages/rust.scm
parent64694083d5e95dcdf9df9cbeb511bed112186570 (diff)
downloadguix-f9a12c1e0275f94b64e459c2796410645a069d53.tar.gz
gnu: rust-1.55: Build with fewer packages.
* gnu/packages/rust.scm (rust-1.55)[inputs]: Remove libssh2, curl.
[native-inputs]: Remove cmake-minimal, which.
(rust)[inputs]: Add curl.

Change-Id: Icf2355e0f84a50ea44bb057c6d6ccd89eead0191
Diffstat (limited to 'gnu/packages/rust.scm')
-rw-r--r--gnu/packages/rust.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index bb8a823bf7..69afc12458 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -513,17 +513,13 @@ ar = \"" binutils "/bin/ar" "\"
                  `("LIBRARY_PATH" ":"
                    suffix (,(string-append libc "/lib"))))))))))
     (native-inputs
-     `(("cmake" ,cmake-minimal)
-       ("pkg-config" ,pkg-config)       ; For "cargo"
+     `(("pkg-config" ,pkg-config)
        ("python" ,python-wrapper)
        ("rustc-bootstrap" ,rust-bootstrap)
-       ("cargo-bootstrap" ,rust-bootstrap "cargo")
-       ("which" ,which)))
+       ("cargo-bootstrap" ,rust-bootstrap "cargo")))
     (inputs
      `(("llvm" ,llvm-13)
-       ("openssl" ,openssl)
-       ("libssh2" ,libssh2)             ; For "cargo"
-       ("libcurl" ,curl)))              ; For "cargo"
+       ("openssl" ,openssl)))
     ;; rustc invokes gcc, so we need to set its search paths accordingly.
     ;; Note: duplicate its value here to cope with circular dependencies among
     ;; modules (see <https://bugs.gnu.org/31392>).
@@ -1073,6 +1069,9 @@ exec -a \"$0\" \"~a\" \"$@\""
                                               "/lib/rustlib/src/rust/library")
                                (string-append bin "/.rust-analyzer-real"))))
                    (chmod (string-append bin "/rust-analyzer") #o755))))))))
+      (inputs
+       (modify-inputs (package-inputs base-rust)
+                      (prepend curl)))
       ;; Add test inputs.
       (native-inputs (cons* `("gdb" ,gdb/pinned)
                             `("procps" ,procps)