summary refs log tree commit diff
path: root/gnu/packages/samba.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-01-15 07:30:08 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-01-15 14:58:33 +0100
commita9691718e894d0645014d0aeb79e3b867345b560 (patch)
treec8cb1a710509decb45f17ae75e2a2b155fb916b4 /gnu/packages/samba.scm
parentfa5e6618593feab0c764652cd632f4e1bf6558a2 (diff)
downloadguix-a9691718e894d0645014d0aeb79e3b867345b560.tar.gz
gnu: iniparser: Update to 4.1.
* gnu/packages/samba.scm (iniparser): Update to 4.1.
[arguments]: Update library SONAME.
[home-page]: Abandon outdated home page with no mention of version 4.
Diffstat (limited to 'gnu/packages/samba.scm')
-rw-r--r--gnu/packages/samba.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index 4de8d89219..7cf02a62cb 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -93,7 +93,7 @@ the Linux kernel CIFS client.")
 (define-public iniparser
   (package
     (name "iniparser")
-    (version "4.0")
+    (version "4.1")
     (source (origin
              (method url-fetch)
              (uri (string-append "https://github.com/ndevilla/iniparser/archive/v"
@@ -101,7 +101,7 @@ the Linux kernel CIFS client.")
              (file-name (string-append name "-" version ".tar.gz"))
              (sha256
               (base32
-               "1flj7srvh2hp9ls96qz922bklyhw7f27mmn23b16839zpdjddfz0"))))
+               "1bpk8dj9d5cl64lg6jsk0qlzrpg848nymwxc3fx707fk1n0al3cn"))))
     (build-system gnu-build-system)
     (arguments
      `(#:make-flags
@@ -115,7 +115,7 @@ the Linux kernel CIFS client.")
                 (string-append (assoc-ref outputs "out") "/lib")))))
          (replace 'build
            (lambda* (#:key make-flags #:allow-other-keys)
-             (apply invoke "make" "libiniparser.so"
+             (apply invoke "make" "libiniparser.so.1"
                     make-flags)))
          (replace 'install
            (lambda* (#:key outputs #:allow-other-keys)
@@ -130,14 +130,14 @@ the Linux kernel CIFS client.")
                (for-each (install lib)
                          (find-files "." "^lib.*\\.so"))
                (with-directory-excursion lib
-                 (symlink "libiniparser.so.0" "libiniparser.so"))
+                 (symlink "libiniparser.so.1" "libiniparser.so"))
                (for-each (install inc)
                          (find-files "src" "\\.h$"))
                (for-each (install html)
                          (find-files "html" ".*"))
                (for-each (install doc)
                          '("AUTHORS" "INSTALL" "LICENSE" "README.md"))))))))
-    (home-page "http://ndevilla.free.fr/iniparser")
+    (home-page "https://github.com/ndevilla/iniparser")
     (synopsis "Standalone ini file parsing library")
     (description
      "iniparser is a free stand-alone `ini' file parsing library (Windows