summary refs log tree commit diff
path: root/gnu/packages/samba.scm
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2024-02-18 12:07:32 +0100
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:44:54 +0200
commitd19ddc9450e98ca7adcd65072754e8f727bcd982 (patch)
tree56607c69dbe031ce36d414804244b41a9ea3147c /gnu/packages/samba.scm
parent19c153c15eff3ed7fdc19205693639201f96c66f (diff)
downloadguix-d19ddc9450e98ca7adcd65072754e8f727bcd982.tar.gz
gnu: tevent: Remove reference to crypt.
* gnu/packages/samba.scm (tevent): Remove reference to crypt header.

Change-Id: Ic99712c9374dee1fd5b65c29327fe39aa10eed35
Diffstat (limited to 'gnu/packages/samba.scm')
-rw-r--r--gnu/packages/samba.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index bf92b210c3..2d1ea5959d 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -397,6 +397,14 @@ destructors.  It is the core memory allocator used in Samba.")
     (arguments
      '(#:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'remove-crypt-reference
+           ;; The following is needed because Python.h propagates
+           ;; HAVE_CRYPT_H, which is then seen from lib/replace/ but talloc
+           ;; doesn't need it at all.
+           (lambda _
+             (substitute* "lib/replace/replace.h"
+               (("#include <crypt.h>")
+                ""))))
          (replace 'configure
            ;; tevent uses a custom configuration script that runs waf.
            (lambda* (#:key outputs #:allow-other-keys)