summary refs log tree commit diff
path: root/gnu/packages/scheme.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-10-09 00:09:04 +0200
committerLudovic Courtès <ludo@gnu.org>2013-10-09 00:11:34 +0200
commit01eafd38fbeb49d8167d99569eb624ab404bbeb2 (patch)
treecfbde1f3b011ee586bf4ce45b7f83d10fc28e2f4 /gnu/packages/scheme.scm
parentac10e0e17e366d354ad8b3f91e03c1bdeddc7632 (diff)
downloadguix-01eafd38fbeb49d8167d99569eb624ab404bbeb2.tar.gz
gnu: Use the 'patches' field of <origin>.
* gnu/packages/apr.scm,
  gnu/packages/autotools.scm,
  gnu/packages/avahi.scm,
  gnu/packages/cdrom.scm,
  gnu/packages/cmake.scm,
  gnu/packages/cpio.scm,
  gnu/packages/cross-base.scm,
  gnu/packages/emacs.scm,
  gnu/packages/flex.scm,
  gnu/packages/fontutils.scm,
  gnu/packages/glib.scm,
  gnu/packages/grub.scm,
  gnu/packages/guile.scm,
  gnu/packages/idutils.scm,
  gnu/packages/libevent.scm,
  gnu/packages/linux.scm,
  gnu/packages/mail.scm,
  gnu/packages/make-bootstrap.scm,
  gnu/packages/mp3.scm,
  gnu/packages/oggvorbis.scm,
  gnu/packages/pdf.scm,
  gnu/packages/plotutils.scm,
  gnu/packages/qemu.scm,
  gnu/packages/recutils.scm,
  gnu/packages/rush.scm,
  gnu/packages/scheme.scm,
  gnu/packages/system.scm,
  gnu/packages/tcsh.scm,
  gnu/packages/valgrind.scm,
  gnu/packages/vpn.scm,
  gnu/packages/w3m: Use the 'patches' field of <origin> instead of
  adding a patch as input plus using #:patches.
Diffstat (limited to 'gnu/packages/scheme.scm')
-rw-r--r--gnu/packages/scheme.scm21
1 files changed, 8 insertions, 13 deletions
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index 0608c41a2f..122262487b 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -125,11 +125,11 @@ development cycle.")
                                  version ".tar.gz"))
              (sha256
               (base32
-               "1fck2h48f0bvh8fl437cagmp0syfxy9lqacy1zwsis20fc76jvzi"))))
+               "1fck2h48f0bvh8fl437cagmp0syfxy9lqacy1zwsis20fc76jvzi"))
+             (patches (list (search-patch "bigloo-gc-shebangs.patch")))))
     (build-system gnu-build-system)
     (arguments
-     `(#:patches (list (assoc-ref %build-inputs "patch/shebangs"))
-       #:test-target "test"
+     `(#:test-target "test"
        #:phases (alist-replace
                  'configure
                  (lambda* (#:key outputs #:allow-other-keys)
@@ -178,7 +178,6 @@ development cycle.")
                   %standard-phases))))
     (inputs
      `(("emacs" ,emacs)
-       ("patch/shebangs" ,(search-patch "bigloo-gc-shebangs.patch"))
 
        ;; Optional APIs for which Bigloo has bindings.
        ("avahi" ,avahi)
@@ -211,7 +210,8 @@ between Scheme and C# programs.")
                                  version ".tar.gz"))
              (sha256
               (base32
-               "1v2r4ga58kk1sx0frn8qa8ccmjpic9csqzpk499wc95y9c4b1wy3"))))
+               "1v2r4ga58kk1sx0frn8qa8ccmjpic9csqzpk499wc95y9c4b1wy3"))
+             (patches (list (search-patch "hop-bigloo-4.0b.patch")))))
     (build-system gnu-build-system)
     (arguments
      '(#:phases
@@ -251,7 +251,6 @@ between Scheme and C# programs.")
                                         "\\.so$")))))
          %standard-phases))
        #:tests? #f                                ; no test suite
-       #:patches (list (assoc-ref %build-inputs "patch/bigloo-4.0b"))
        #:modules ((guix build gnu-build-system)
                   (guix build utils)
                   (ice-9 popen)
@@ -260,10 +259,7 @@ between Scheme and C# programs.")
                   (srfi srfi-1))))
     (inputs `(("bigloo" ,bigloo)
               ("which" ,which)
-              ("patchelf" ,patchelf)
-
-              ("patch/bigloo-4.0b"
-               ,(search-patch "hop-bigloo-4.0b.patch"))))
+              ("patchelf" ,patchelf)))
     (home-page "http://hop.inria.fr/")
     (synopsis "A multi-tier programming language for the Web 2.0")
     (description
@@ -324,10 +320,9 @@ language standard, and includes many enhancements and extensions.")
                                  "/scheme48-" version ".tgz"))
              (sha256
               (base32
-               "0rw2lz5xgld0klvld292ds6hvfk5l12vskzgf1hhwjdpa38r3fnw"))))
+               "0rw2lz5xgld0klvld292ds6hvfk5l12vskzgf1hhwjdpa38r3fnw"))
+             (patches (list (search-patch "scheme48-tests.patch")))))
     (build-system gnu-build-system)
-    (arguments `(#:patches (list (assoc-ref %build-inputs "patch/tests"))))
-    (inputs `(("patch/tests" ,(search-patch "scheme48-tests.patch"))))
     (home-page "http://s48.org/")
     (synopsis "Scheme implementation using a bytecode interpreter")
     (description