summary refs log tree commit diff
path: root/gnu/packages/scheme.scm
diff options
context:
space:
mode:
authorKei Kebreau <kei@openmailbox.org>2017-07-03 14:34:34 -0400
committerKei Kebreau <kei@openmailbox.org>2017-07-10 19:35:44 -0400
commit082725b5027a3782f242b634f94b9049d4c7f309 (patch)
tree7593e8bd9d4d6bcf795954624c02255269fddb26 /gnu/packages/scheme.scm
parent5e3ea571c5ac10858b2a1d6d3dc94a26408ae601 (diff)
downloadguix-082725b5027a3782f242b634f94b9049d4c7f309.tar.gz
gnu: hop: Update to 3.1.0-pre2.
* gnu/packages/scheme.scm (hop): Update to 3.1.0-pre2.
[source]: Remove unnecessary patch.
[arguments]: Enable tests; disable parallel building; specify BIGLOO in
make-flags.
[inputs]: Add libgc, libunistring, libuv, pcre and sqlite.
* gnu/local.mk (dist_patch_DATA): Remove unnecessary patch.
* gnu/packages/patches/hop-linker-flags.patch: Delete file.
Diffstat (limited to 'gnu/packages/scheme.scm')
-rw-r--r--gnu/packages/scheme.scm23
1 files changed, 15 insertions, 8 deletions
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index 8c8922d89f..92c0170205 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -288,21 +288,23 @@ Scheme and C programs and between Scheme and Java programs.")
 (define-public hop
   (package
     (name "hop")
-    (version "2.5.1")
+    (version "3.1.0-pre2")
     (source (origin
              (method url-fetch)
              (uri (string-append "ftp://ftp-sop.inria.fr/indes/fp/Hop/hop-"
                                  version ".tar.gz"))
              (sha256
               (base32
-               "1bvp7pc71bln5yvfj87s8750c6l53wjl6f8m12v62q9926adhwys"))
-             (patches (search-patches "hop-linker-flags.patch"))))
+               "09m7pahjsp7wxzd20cdph9j3mgf2nq5dyckcjljcd40m25v85kks"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:phases
+     `(#:test-target "test"
+       #:make-flags '("BIGLOO=bigloo")
+       #:parallel-build? #f
+       #:phases
        (modify-phases %standard-phases
          (replace 'configure
-           (lambda* (#:key outputs #:allow-other-keys)
+           (lambda* (#:key inputs outputs #:allow-other-keys)
              (let ((out (assoc-ref outputs "out")))
                (zero?
                 (system* "./configure"
@@ -310,11 +312,16 @@ Scheme and C programs and between Scheme and Java programs.")
                          (string-append "--blflags="
                                         ;; user flags completely override useful
                                         ;; default flags, so repeat them here.
-                                        "-copt \\$(CPICFLAGS) -L\\$(BUILDLIBDIR) "
-                                        "-ldopt -Wl,-rpath," out "/lib")))))))
-       #:tests? #f))                                ; no test suite
+                                        "-copt \\$(CPICFLAGS) "
+                                        "-L \\$(BUILDLIBDIR) "
+                                        "-ldopt -Wl,-rpath," out "/lib")))))))))
     (inputs `(("avahi" ,avahi)
               ("bigloo" ,bigloo)
+              ("libgc" ,libgc)
+              ("libunistring" ,libunistring)
+              ("libuv" ,libuv)
+              ("pcre" ,pcre)
+              ("sqlite" ,sqlite)
               ("which" ,which)))
     (home-page "http://hop.inria.fr/")
     (synopsis "Multi-tier programming language for the Web 2.0")