summary refs log tree commit diff
path: root/gnu/packages/scheme.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-10-22 02:12:22 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-10-22 03:31:19 +0200
commite0840e2b1c3c139a826b05adb33563274c14e9d8 (patch)
treec75cf9425e9699adaa63a98686c263ed1485a869 /gnu/packages/scheme.scm
parent713659f44979d426a45d47005e4591687740e45b (diff)
downloadguix-e0840e2b1c3c139a826b05adb33563274c14e9d8.tar.gz
gnu: chibi-scheme: Cross-compile.
* gnu/packages/scheme.scm (chibi-scheme)[arguments]: Set CC to
CC-FOR-TARGET in #:make-flags rather than hard-coding it to "gcc" as an
environment variable.
Diffstat (limited to 'gnu/packages/scheme.scm')
-rw-r--r--gnu/packages/scheme.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index de56626ee3..544c24970a 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -455,13 +455,12 @@ mixed.")
         (base32 "0yhmj0lws3r3bl4ivs31dhlzxqc7f0dinixi904mraz1fmrg3w7f"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:phases (modify-phases %standard-phases
-                  (delete 'configure)
-                  (add-before 'build 'set-cc
-                    (lambda _
-                      (setenv "CC" "gcc"))))
+     `(#:phases
+       (modify-phases %standard-phases
+         (delete 'configure))           ; no configure script
        #:make-flags (let ((out (assoc-ref %outputs "out")))
                       (list (string-append "PREFIX=" out)
+                            (string-append "CC=" ,(cc-for-target))
                             (string-append "LDFLAGS=-Wl,-rpath=" out "/lib")))
        #:test-target "test"))
     (synopsis "Small embeddable Scheme implementation")