summary refs log tree commit diff
path: root/gnu/packages/shells.scm
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2022-04-01 15:16:07 +0000
committerLudovic Courtès <ludo@gnu.org>2022-04-03 12:42:18 +0200
commita37a8a23bdcc20e5da2460faa2f3f47865c34784 (patch)
treea5c7d76f26e16765d508fc9152be9c96d3582a13 /gnu/packages/shells.scm
parent032f2e261caee641d29ebc604a7d7a9be2410ac7 (diff)
downloadguix-a37a8a23bdcc20e5da2460faa2f3f47865c34784.tar.gz
gnu: oil: Update to 0.9.9.
* gnu/packages/shells.scm (oil): Update to 0.9.9.
  [source]: Add comment on embedded CPython like Ludo’ proposed in
  https://issues.guix.gnu.org/53642#3.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/shells.scm')
-rw-r--r--gnu/packages/shells.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index dda670d237..3a48bc7dbf 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -18,7 +18,7 @@
 ;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2020, 2022 Marius Bakke <marius@gnu.org>
 ;;; Copyright © 2021, 2022 Nicolas Goaziou <mail@nicolasgoaziou.fr>
-;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
+;;; Copyright © 2021, 2022 Felix Gruber <felgru@posteo.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -834,14 +834,20 @@ Shell (pdksh).")
 (define-public oil
   (package
     (name "oil")
-    (version "0.9.7")
+    (version "0.9.9")
     (source
+     ;; oil's sources contain a modified version of CPython 2.7.13.
+     ;; According to https://www.oilshell.org/blog/2017/05/05.html
+     ;; this bundles version of CPython had certain unused parts removed
+     ;; and its build system has been replaced by a custom one.
+     ;; This would probably make it quite complicated to replace the
+     ;; bundled CPython with the one from the python2 package.
      (origin
        (method url-fetch)
        (uri (string-append "https://www.oilshell.org/download/oil-"
                            version ".tar.gz"))
        (sha256
-        (base32 "09ill1wks8gmixfc648wx25wx0wzlgkjj34bbpglx496i6yp81aw"))))
+        (base32 "1ymszq0wy7sy709yqx8dpmv7b37fkc57bdg02ah2gnjbvbk6s2z1"))))
     (build-system gnu-build-system)
     (arguments
      (list #:strip-binaries? #f         ; strip breaks the binary