summary refs log tree commit diff
path: root/gnu/packages/simulation.scm
diff options
context:
space:
mode:
authorreza <reza@housseini.me>2023-06-24 21:42:58 +0000
committerLudovic Courtès <ludo@gnu.org>2023-08-10 09:26:08 +0200
commit997b38badaee20a1c60411e5e599e260e47785ec (patch)
tree8feff7dd97dd2e0087046ab8157a7f0b8cf8eefb /gnu/packages/simulation.scm
parent5d77091cfc80b1f4b622ada760f54a3bae844e74 (diff)
downloadguix-997b38badaee20a1c60411e5e599e260e47785ec.tar.gz
gnu: Add openfoam-com.
* gnu/packages/simulation.scm (openfoam-com): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/simulation.scm')
-rw-r--r--gnu/packages/simulation.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/simulation.scm b/gnu/packages/simulation.scm
index 70d2aac17a..1dd6dc63f7 100644
--- a/gnu/packages/simulation.scm
+++ b/gnu/packages/simulation.scm
@@ -397,6 +397,40 @@ problems for efficient solution on parallel systems.")
 (define-public openfoam
   (deprecated-package "openfoam" openfoam-org))
 
+(define-public openfoam-com
+  ;; This is a fork of 'openfoam-org', maintained separately.
+  (package
+    (inherit openfoam-org)
+    (name "openfoam-com")
+    (version "2212")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://develop.openfoam.com"
+                                  "/Development/openfoam/-/archive/OpenFOAM-v"
+                                  version
+                                  "/openfoam-OpenFOAM-v"
+                                  version
+                                  ".tar.gz"))
+              (sha256
+               (base32
+                "0i9039hfz9gvgymkdjhjvvn5500zha3cpdbpqrzfrfi8lbz10is2"))
+              (modules '((guix build utils)))
+              (snippet `(begin
+                          (substitute* "etc/bashrc"
+                            ;; set same version as guix package
+			    (("^export WM_PROJECT_VERSION=.*$")
+			     (string-append "export WM_PROJECT_VERSION="
+					    ,version "\n")))
+                          ;; patch shell paths
+                          (substitute* (list "src/OSspecific/POSIX/POSIX.C"
+                                             "wmake/src/Makefile"
+                                             "wmake/makefiles/general"
+                                             "wmake/makefiles/info")
+                            (("/bin/sh")
+                             "sh"))))))
+    (synopsis "Framework for numerical simulation of fluid flow (from openfoam.com)")
+    (home-page "https://www.openfoam.com")))
+
 (define-public open-simulation-interface
   (package
     (name "open-simulation-interface")