summary refs log tree commit diff
path: root/gnu/packages/slim.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2014-04-27 11:09:07 +0200
committerAndreas Enge <andreas@enge.fr>2014-04-27 11:35:26 +0200
commit06ed59825ecc0dc78d4d16d06c129e2f4879201a (patch)
tree6e0efd0e943bf012d0b1127c9d1bf7fcad96b36c /gnu/packages/slim.scm
parent5d17cf8eb96e7f266c3ec8d9e512389d1875401b (diff)
downloadguix-06ed59825ecc0dc78d4d16d06c129e2f4879201a.tar.gz
guix: cmake: Add input and package libraries to the rpath, and adapt package
  definitions accordingly.

* guix/build/cmake-build-system.scm (configure): Add flags.
* gnu/packages/maths.scm (lapack): Drop special code.
* gnu/packages/ssh.scm (libssh): Drop special code.
* gnu/packages/slim.scm (slim): Drop special code and enable shared library.

Co-authored-by: Eric Bavier <bavier@member.fsf.org>
Diffstat (limited to 'gnu/packages/slim.scm')
-rw-r--r--gnu/packages/slim.scm12
1 files changed, 3 insertions, 9 deletions
diff --git a/gnu/packages/slim.scm b/gnu/packages/slim.scm
index f25b070f3c..cea3748985 100644
--- a/gnu/packages/slim.scm
+++ b/gnu/packages/slim.scm
@@ -1,6 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013 Guy Grant <gzg@riseup.net>
 ;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2014 Andreas Enge <andreas@enge.fr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -75,15 +76,8 @@
                       ;; "systemd".  Strip that.
                       "")))
 		 %standard-phases)
-       #:configure-flags '("-DUSE_PAM=yes" "-DUSE_CONSOLEKIT=no"
-
-                           ;; Don't build libslim.so, because then the build
-                           ;; system is unable to set the right RUNPATH on the
-                           ;; 'slim' binary.
-                           "-DBUILD_SHARED_LIBS=OFF"
-
-                           ;; Leave a valid RUNPATH upon install.
-                           "-DCMAKE_SKIP_BUILD_RPATH=ON")
+       #:configure-flags '("-DUSE_PAM=yes"
+                           "-DUSE_CONSOLEKIT=no")
        #:tests? #f))
     (home-page "http://slim.berlios.de/")
     (synopsis "Desktop-independent graphcal login manager for X11")