summary refs log tree commit diff
path: root/gnu/packages/speech.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-03-29 17:06:18 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-03-29 19:39:18 +0200
commit692c75eaa6c87c73ad2e20cbded6c32b9ae6b8a2 (patch)
treeb410ad42e61f7f10a2daa4cbd0783c43e14f445f /gnu/packages/speech.scm
parent6a2c78288a77ce6d860f52b6f600cab5f199a1b4 (diff)
downloadguix-692c75eaa6c87c73ad2e20cbded6c32b9ae6b8a2.tar.gz
gnu: flite: Update to 2.2.
* gnu/packages/speech.scm (flite): Update to 2.2.
[source]: Check out this git repository.
Diffstat (limited to 'gnu/packages/speech.scm')
-rw-r--r--gnu/packages/speech.scm15
1 files changed, 8 insertions, 7 deletions
diff --git a/gnu/packages/speech.scm b/gnu/packages/speech.scm
index 687a3c10cf..093f6f957b 100644
--- a/gnu/packages/speech.scm
+++ b/gnu/packages/speech.scm
@@ -2,7 +2,7 @@
 ;;; Copyright © 2016 David Thompson <davet@gnu.org>
 ;;; Copyright © 2016, 2019, 2020 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
-;;; Copyright © 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018, 2020, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2016 Kei Kebreau <kkebreau@posteo.net>
 ;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
@@ -55,15 +55,16 @@
 (define-public flite
   (package
     (name "flite")
-    (version "2.1")
+    (version "2.2")
     (source
      (origin
-       (method url-fetch)
-       (uri
-        (string-append "http://www.festvox.org/" name "/packed/" name
-                       "-" version "/" name "-" version "-release.tar.bz2"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/festvox/flite")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
        (sha256
-        (base32 "119b7l7pjb1l5raqq24p8rmhdqni49vjh2mgdryrfr575rm3yg67"))))
+        (base32 "1n0p81jzndzc1rzgm66kw9ls189ricy5v1ps11y0p2fk1p56kbjf"))))
     (build-system gnu-build-system)
     (arguments
      ;; XXX: