summary refs log tree commit diff
path: root/gnu/packages/sphinx.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-05-13 09:59:24 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-05-13 11:03:52 +0200
commit1a2eb983cbbc597603a1c7636bb9661d9b34ef91 (patch)
tree474dc588810cef54cd1525522e30c03b9529652d /gnu/packages/sphinx.scm
parentcf89a215cec346bc4d6622cbe353c058452b29b2 (diff)
downloadguix-1a2eb983cbbc597603a1c7636bb9661d9b34ef91.tar.gz
gnu: python-sphinx-panels: Use older docutils.
* gnu/packages/sphinx.scm (python-sphinx-panels)[propagated-inputs]: Replace
python-docutils with python-docutils-0.15.
[build-system]: Use pyproject-build-system.
[arguments]: Remove custom 'check phase.
Diffstat (limited to 'gnu/packages/sphinx.scm')
-rw-r--r--gnu/packages/sphinx.scm13
1 files changed, 3 insertions, 10 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 94873c712b..65b3dc4ec5 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -1,6 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2014 David Thompson <davet@gnu.org>
-;;; Copyright © 2015, 2017, 2019, 2020, 2021 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2017, 2019, 2020, 2021, 2023 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2015, 2016, 2017 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
 ;;; Copyright © 2016-2019, 2022 Marius Bakke <marius@gnu.org>
@@ -368,15 +368,8 @@ Blog, News or Announcements section to a Sphinx website.")
         (file-name (git-file-name name version))
         (sha256
          (base32 "1ivqz6yv96a2jp59kylg1gbkrmzq6zwilppz3ij0zrkjn25zb97k"))))
-    (build-system python-build-system)
-    (arguments
-     '(#:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda* (#:key tests? #:allow-other-keys)
-             (when tests?
-               (invoke "pytest")))))))
-    (propagated-inputs (list python-docutils python-sphinx-4))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list python-docutils-0.15 python-sphinx-4))
     (native-inputs
      (list python-pytest
            python-pytest-regressions))