summary refs log tree commit diff
path: root/gnu/packages/spice.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-04-10 15:53:19 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-04-10 15:53:19 +0200
commit29c6fb0d33b3bea8677093eed1cfbd6483c9fbe8 (patch)
tree8539d80c686d6f5ea9eff9d5056a56971f76099a /gnu/packages/spice.scm
parentd523eb5c9c2659cbbaf4eeef3691234ae527ee6a (diff)
downloadguix-29c6fb0d33b3bea8677093eed1cfbd6483c9fbe8.tar.gz
gnu: spice-gtk: Add an absolute reference for libjpeg in the .la files.
* gnu/packages/spice.scm (spice-gtk)[arguments]: Add phase 'patch-la-files.
Diffstat (limited to 'gnu/packages/spice.scm')
-rw-r--r--gnu/packages/spice.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/spice.scm b/gnu/packages/spice.scm
index 8b688ea9ef..b1b53962aa 100644
--- a/gnu/packages/spice.scm
+++ b/gnu/packages/spice.scm
@@ -2,7 +2,7 @@
 ;;; Copyright © 2016 David Craven <david@craven.ch>
 ;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2019 Rutger Helling <rhelling@mykolab.com>
-;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2019, 2020 Marius Bakke <mbakke@fastmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -175,6 +175,16 @@ which allows users to view a desktop computing environment.")
                (substitute* "tests/Makefile"
                  (("test-session\\$\\(EXEEXT\\) ") ""))
                #t))
+           (add-after 'install 'patch-la-files
+             (lambda* (#:key inputs outputs #:allow-other-keys)
+               (let ((out (assoc-ref outputs "out"))
+                     (libjpeg (assoc-ref inputs "libjpeg")))
+                 ;; Add an absolute reference for libjpeg in the .la files
+                 ;; so it does not have to be propagated.
+                 (substitute* (find-files (string-append out "/lib") "\\.la$")
+                   (("-ljpeg")
+                    (string-append "-L" libjpeg "/lib -ljpeg")))
+                 #t)))
            (add-after
             'install 'wrap-spicy
             (lambda* (#:key inputs outputs #:allow-other-keys)