summary refs log tree commit diff
path: root/gnu/packages/spice.scm
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-07-24 19:52:25 +0200
committerLeo Famulari <leo@famulari.name>2016-07-28 17:08:41 -0400
commit2ef2654de44014664ad99d05e3095ff60535c611 (patch)
treec3c624b31cc1b7236a3c3125ade67289f890cd59 /gnu/packages/spice.scm
parent1d2c67c11e61f2fe10c926d1cf82dfbbe9b1e5f7 (diff)
downloadguix-2ef2654de44014664ad99d05e3095ff60535c611.tar.gz
gnu: Add virglrenderer.
* gnu/packages/spice.scm (virglrenderer): New variable.

Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/spice.scm')
-rw-r--r--gnu/packages/spice.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/spice.scm b/gnu/packages/spice.scm
index c88491fbd9..797b19a2e4 100644
--- a/gnu/packages/spice.scm
+++ b/gnu/packages/spice.scm
@@ -18,7 +18,9 @@
 
 (define-module (gnu packages spice)
   #:use-module (gnu packages)
+  #:use-module (gnu packages gl)
   #:use-module (gnu packages libusb)
+  #:use-module (gnu packages linux)
   #:use-module (gnu packages pkg-config)
   #:use-module (guix build-system gnu)
   #:use-module (guix download)
@@ -50,3 +52,28 @@ to a different (virtual) machine than the one to which the USB device is
 attached.")
     (home-page "http://www.spice-space.org")
     (license (list license:gpl2+ license:lgpl2.0+ license:lgpl2.1+))))
+
+(define-public virglrenderer
+  (package
+    (name "virglrenderer")
+    (version "0.5.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                "https://www.freedesktop.org/software/virgl/"
+                "virglrenderer-" version ".tar.bz2"))
+              (sha256
+               (base32
+                "1dj0j8nbyr7nrpds4dqlp43ji8ixjyqhgw6ywlz1r9dn6cs5m5d1"))))
+    (build-system gnu-build-system)
+    (inputs
+      `(("libepoxy" ,libepoxy)
+        ("mesa" ,mesa)
+        ("udev" ,eudev)))
+    (native-inputs
+      `(("pkg-config" ,pkg-config)))
+    (synopsis "Virtual 3D GPU library")
+    (description "A virtual 3D GPU library that enables a virtualized operating
+system to use the host GPU to accelerate 3D rendering.")
+    (home-page "https://virgil3d.github.io")
+    (license (list license:expat license:bsd-3))))