summary refs log tree commit diff
path: root/gnu/packages/spice.scm
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-07-24 19:52:29 +0200
committerLeo Famulari <leo@famulari.name>2016-07-28 17:08:42 -0400
commit33b0f4a4b2fb4eea8a3edb59e272e338bd1bf261 (patch)
tree5eca5318004f62d3cea1b5d54cb90ba533728289 /gnu/packages/spice.scm
parent3cbd37e4408ea9c827a62c43946cda7b486a32f1 (diff)
downloadguix-33b0f4a4b2fb4eea8a3edb59e272e338bd1bf261.tar.gz
gnu: Add spice-vdagent.
* gnu/packages/spice.scm (spice-vdagent): New variable.

Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/spice.scm')
-rw-r--r--gnu/packages/spice.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/spice.scm b/gnu/packages/spice.scm
index 2976f88763..581c2cd9e0 100644
--- a/gnu/packages/spice.scm
+++ b/gnu/packages/spice.scm
@@ -209,3 +209,47 @@ not only on the machine where it is running, but from anywhere on the
 Internet and from a wide variety of machine architectures.")
     (home-page "http://www.spice-space.org")
     (license (list license:lgpl2.1+ license:lgpl2.0+))))
+
+(define-public spice-vdagent
+  (package
+    (name "spice-vdagent")
+    (version "0.17.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                "http://www.spice-space.org/download/releases/"
+                "spice-vdagent-" version ".tar.bz2"))
+              (sha256
+               (base32
+                "0gdkyylyg1hksg0i0anvznqfli2q39335fnrmcd6847frpc8njpi"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:configure-flags
+       '("--localstatedir=/var")
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'patch-makefile.in
+           (lambda _
+             (substitute* "Makefile.in"
+               (((string-append "\\$\\(mkdir_p\\) \\$\\(DESTDIR\\)"
+                                "\\$\\(localstatedir\\)/run/spice-vdagentd"))
+                 "-$(mkdir_p) $(DESTDIR)$(localstatedir)/run/spice-vdagentd"))
+             #t)))))
+    (inputs
+      `(("alsa-lib" ,alsa-lib)
+        ("dbus" ,dbus)
+        ("glib" ,glib)
+        ("libpciaccess" ,libpciaccess)
+        ("libx11" ,libx11)
+        ("libxext" ,libxext)
+        ("libxfixes" ,libxfixes)
+        ("libxinerama" ,libxinerama)
+        ("libxrandr" ,libxrandr)
+        ("spice-protocol" ,spice-protocol)))
+    (native-inputs
+      `(("pkg-config" ,pkg-config)))
+    (synopsis "Spice agent for Linux")
+    (description "Spice-vdagent enables sharing the clipboard and guest display
+resolution scaling on graphical console window resize.")
+    (home-page "http://www.spice-space.org")
+    (license license:gpl3+)))