summary refs log tree commit diff
path: root/gnu/packages/spice.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-04-16 21:00:27 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-04-16 21:19:34 +0200
commitfbd2a245f7c6caaa231658300fa2eaf7beca1e32 (patch)
tree8916a2557b6f626bdb95213e6accfb9d9d889ce8 /gnu/packages/spice.scm
parenta2d2c0bffe08e40dad46f557d36d2261c077ef43 (diff)
downloadguix-fbd2a245f7c6caaa231658300fa2eaf7beca1e32.tar.gz
gnu: spice-gtk: Update to 0.36.
* gnu/packages/spice.scm (spice-gtk): Update to 0.36.
[inputs]: Add JSON-GLIB.
[arguments]: Disable session test.
Diffstat (limited to 'gnu/packages/spice.scm')
-rw-r--r--gnu/packages/spice.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/spice.scm b/gnu/packages/spice.scm
index 3a8c5a5d85..52e4f4f7f6 100644
--- a/gnu/packages/spice.scm
+++ b/gnu/packages/spice.scm
@@ -117,7 +117,7 @@ which allows users to view a desktop computing environment.")
 (define-public spice-gtk
   (package
     (name "spice-gtk")
-    (version "0.35")
+    (version "0.36")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -125,7 +125,7 @@ which allows users to view a desktop computing environment.")
                 "spice-gtk-" version ".tar.bz2"))
               (sha256
                (base32
-                "11lymg467gvj5ys8k22ihnfbxjn4x34ygyzirpg2nphjwlyhgrml"))))
+                "1kfpixfdmxs9wn3id48gc9bvfrgxz935y3wpykf40bgi9mcc69ki"))))
     (build-system gnu-build-system)
     (propagated-inputs
       `(("gstreamer" ,gstreamer)
@@ -143,6 +143,7 @@ which allows users to view a desktop computing environment.")
     (inputs
       `(("glib-networking" ,glib-networking)
         ("gobject-introspection" ,gobject-introspection)
+        ("json-glib" ,json-glib)
         ("libepoxy" ,libepoxy)
         ("libjpeg" ,libjpeg)
         ("libxcb" ,libxcb)
@@ -164,6 +165,13 @@ which allows users to view a desktop computing environment.")
           "--enable-introspection")
         #:phases
          (modify-phases %standard-phases
+           (add-before 'check 'disable-session-test
+             (lambda _
+               ;; XXX: Disable session tests, because they require USB support,
+               ;; which is not available in the build container.
+               (substitute* "tests/Makefile"
+                 (("test-session\\$\\(EXEEXT\\) ") ""))
+               #t))
            (add-after
             'install 'wrap-spicy
             (lambda* (#:key inputs outputs #:allow-other-keys)