summary refs log tree commit diff
path: root/gnu/packages/spreadsheet.scm
diff options
context:
space:
mode:
authorJorge Gomez <jgart@dismail.de>2021-11-18 20:22:19 -0500
committerLeo Famulari <leo@famulari.name>2021-11-22 16:16:28 -0500
commit10fad03fcf6fdd2edbdab5f939e3c0edb11a88e2 (patch)
treeee24df774ef86e5081b88a474fcf9ed42e6fd0e6 /gnu/packages/spreadsheet.scm
parentc4bc557c3a2e59b0d127f1a8a963e1a19daf6cdb (diff)
downloadguix-10fad03fcf6fdd2edbdab5f939e3c0edb11a88e2.tar.gz
gnu: Move visidata to (gnu packages spreadsheet).
See <http://issues.guix.gnu.org/47852>.

* gnu/packages/visidata.scm (visidata): Move from here…
* gnu/packages/spreadsheet.scm (visidata): …to here.
* gnu/local.mk (GNU_SYSTEM_MODULES): Adjust accordingly.

Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/spreadsheet.scm')
-rw-r--r--gnu/packages/spreadsheet.scm51
1 files changed, 46 insertions, 5 deletions
diff --git a/gnu/packages/spreadsheet.scm b/gnu/packages/spreadsheet.scm
index 2c0b539c55..99ff1bbff0 100644
--- a/gnu/packages/spreadsheet.scm
+++ b/gnu/packages/spreadsheet.scm
@@ -1,4 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
 ;;; Copyright © 2020 Ekaitz Zarraga <ekaitz@elenq.tech>
 ;;; Copyright © 2021 Jorge Gomez <jgart@dismail.de>
 ;;;
@@ -23,15 +24,20 @@
   #:use-module (guix download)
   #:use-module (guix utils)
   #:use-module (guix build-system gnu)
+  #:use-module (guix build-system python)
   #:use-module (guix licenses)
   #:use-module (gnu packages base)
-  #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages bison)
+  #:use-module (gnu packages check)
+  #:use-module (gnu packages compression)
   #:use-module (gnu packages maths)
+  #:use-module (gnu packages ncurses)
+  #:use-module (gnu packages time)
+  #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages python-web)
+  #:use-module (gnu packages python-xyz)
   #:use-module (gnu packages statistics)
-  #:use-module (gnu packages xml)
-  #:use-module (gnu packages compression)
-  #:use-module (gnu packages bison)
-  #:use-module (gnu packages ncurses))
+  #:use-module (gnu packages xml))
 
 (define-public sc-im
     (package
@@ -78,3 +84,38 @@
  providing a vim-like experience.  @code{sc-im} supports @{gnuplot} interaction,
  functions for sorting and filtering, 256 color support, and much more.")
       (license bsd-4)))
+
+(define-public visidata
+  (package
+    (name "visidata")
+    (version "2.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "visidata" version))
+       (sha256
+        (base32
+         "19fbjr9j91pcazcz0bqx3qrasmr8xdsb13haf5lfbpyxj23f7f1j"))))
+    (build-system python-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests? (invoke "pytest"))
+             #t)))))
+    (inputs
+     `(("dateutil" ,python-dateutil)
+       ("requests" ,python-requests)
+       ("lxml" ,python-lxml)
+       ("openpyxl" ,python-openpyxl)
+       ("xlrd" ,python-xlrd)))
+    (native-inputs
+     `(("pytest" ,python-pytest)))
+    (synopsis "Terminal spreadsheet multitool for discovering and arranging data")
+    (description
+     "VisiData is an interactive multitool for tabular data.  It combines the
+clarity of a spreadsheet, the efficiency of the terminal, and the power of
+Python, into a lightweight utility which can handle millions of rows.")
+    (home-page "https://www.visidata.org/")
+    (license gpl3)))