summary refs log tree commit diff
path: root/gnu/packages/sssd.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2017-05-15 16:01:21 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-05-15 21:26:50 +0200
commitdbe874dcbf349b1629a7222db3d7c14241ad5606 (patch)
tree3c0c96965fc992c7b829a29975650962fd9812a6 /gnu/packages/sssd.scm
parent751f8582b5051c57a1c23b438d6a295902828fcf (diff)
downloadguix-dbe874dcbf349b1629a7222db3d7c14241ad5606.tar.gz
gnu: Add ding-libs.
* gnu/packages/sssd.scm: New file.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
Diffstat (limited to 'gnu/packages/sssd.scm')
-rw-r--r--gnu/packages/sssd.scm51
1 files changed, 51 insertions, 0 deletions
diff --git a/gnu/packages/sssd.scm b/gnu/packages/sssd.scm
new file mode 100644
index 0000000000..bf16e6b002
--- /dev/null
+++ b/gnu/packages/sssd.scm
@@ -0,0 +1,51 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages sssd)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix packages)
+  #:use-module (guix download)
+  #:use-module (guix utils)
+  #:use-module (guix build-system gnu)
+  #:use-module (gnu packages))
+
+(define-public ding-libs
+  (package
+    (name "ding-libs")
+    (version "0.6.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://releases.pagure.org/SSSD/ding-libs/"
+                                  "ding-libs-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1bczkvq7cblp75kqn6r2d7j5x7brfw6wxirzc6d2rkyb80gj2jkn"))))
+    (build-system gnu-build-system)
+    (home-page "https://pagure.io/SSSD/ding-libs/")
+    (synopsis "Libraries for SSSD")
+    (description
+     "DING-LIBS (DING Is Not Glib) are a set of small, useful libraries that
+the @dfn{System Security Services Daemon} (SSSD) uses and makes available to
+other projects.  They include: libdhash, an implementation of a dynamic hash
+table which will dynamically resize to achieve optimal storage and access time
+properties; ini_config, a library for parsing and managing @code{INI} files;
+path_utils, a library to manage UNIX paths and subsets of paths; collection, a
+generic, hierarchical grouping mechanism for complex data sets; ref_array, a
+dynamically-growing, reference-counted array; libbasicobjects, a set of
+fundamental object types for C.")
+    (license license:lgpl3+)))