summary refs log tree commit diff
path: root/gnu/packages/statistics.scm
diff options
context:
space:
mode:
authorBonfaceKilz <me@bonfacemunyoki.com>2021-06-18 10:38:11 +0300
committerLudovic Courtès <ludo@gnu.org>2021-06-26 22:49:10 +0200
commit452b7a75109182a7eb1a7791859f4fd076f81853 (patch)
tree90197c73432db6582b5c70bce193f40225fd54ac /gnu/packages/statistics.scm
parent68e378913914f35e40b05108c709f4d1eb55b18a (diff)
downloadguix-452b7a75109182a7eb1a7791859f4fd076f81853.tar.gz
gnu: python-rpy2: Update to 3.4.5.
* gnu/packages/statistics.scm (python-rpy2): Update to 3.4.5
[source]: Remove the patches.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/statistics.scm')
-rw-r--r--gnu/packages/statistics.scm22
1 files changed, 3 insertions, 19 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 1292ac6898..e5c5313c60 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -12,6 +12,7 @@
 ;;; Copyright © 2017 Alex Kost <alezost@gmail.com>
 ;;; Copyright © 2018 Alex Branham <alex.branham@gmail.com>
 ;;; Copyright © 2020 Tim Howes <timhowes@lavabit.com>
+;;; Copyright © 2021 Bonface Munyoki Kilyungi <me@bonfacemunyoki.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -5731,31 +5732,14 @@ to any arbitrary string.  In this case, it is up to you to set valid values.")
 (define-public python-rpy2
   (package
     (name "python-rpy2")
-    (version "3.3.5")
+    (version "3.4.5")
     (source
       (origin
         (method url-fetch)
         (uri (pypi-uri "rpy2" version))
         (sha256
          (base32
-          "1bs36rds5fq8821l5q85q2b25161rs9ppw5c26x0hjwj487gpcfj"))
-        ;; These patches should be removed with the next release.
-        (patches
-          (list
-            (origin
-              (method url-fetch)
-              (uri "https://github.com/rpy2/rpy2/commit/04c57598f00145d868ea8da31ac1b1e7c49f7570.patch")
-              (file-name "python-rpy2-fix-test-failure.patch")
-              (sha256
-               (base32
-                "1lqd3yxjfx1rxrybcmnapy0r6ambg9myrb98q4nlfhpxanwfdbbh")))
-            (origin
-              (method url-fetch)
-              (uri "https://github.com/rpy2/rpy2/commit/685f67d0a6b47ea80e718116a10755019446aef7.patch")
-              (file-name "python-rpy2-r-console-test-fix.patch")
-              (sha256
-               (base32
-                "18wpvfaa4c13d44cb4sw88c3c7403xdy5m8h82wfq8fjmcq3cmzn")))))))
+          "1cysswxr5glrdblyl2zsmywcj7xhxn3wmyihxinrz9gm8gmaacax"))))
     (build-system python-build-system)
     (arguments
      '(#:modules ((ice-9 ftw)