summary refs log tree commit diff
path: root/gnu/packages/statistics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-11-22 18:59:56 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-11-24 12:32:09 +0100
commitffe149ccc5a1c0d06b4e6b81f970808fbf4025e8 (patch)
tree93242875cd01c3e252aa5b91fa7c053bfef44c0b /gnu/packages/statistics.scm
parentf3004710faded7a605bb9dd585214e4e77b3363b (diff)
downloadguix-ffe149ccc5a1c0d06b4e6b81f970808fbf4025e8.tar.gz
gnu: r-with-tests: Drop labels from input lists.
* gnu/packages/statistics.scm (r-with-tests)[native-inputs]: Drop input
labels.
[inputs]: Same.
(r-minimal)[arguments]: Remove lookup of "texlive" package.
Diffstat (limited to 'gnu/packages/statistics.scm')
-rw-r--r--gnu/packages/statistics.scm84
1 files changed, 41 insertions, 43 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index ba937e8c4b..02c3b98ae6 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -366,48 +366,48 @@ as.POSIXct(if (\"\" != Sys.getenv(\"SOURCE_DATE_EPOCH\")) {\
     ;; As the JDK is a rather large input with only very limited effects on R,
     ;; we decided to drop it.
     (native-inputs
-     `(("bzip2" ,bzip2)
-       ("perl" ,perl)
-       ("pkg-config" ,pkg-config)
-       ("texinfo" ,texinfo) ; for building HTML manuals
-       ("texlive" ,(texlive-updmap.cfg (list texlive-ae
-                                        texlive-inconsolata
-                                        texlive-fonts-ec
-                                        texlive-grfext
-                                        texlive-amsfonts
-                                        texlive-latex-base
-                                        texlive-latex-fancyvrb
-                                        texlive-latex-graphics
-                                        texlive-hyperref
-                                        texlive-oberdiek
-                                        texlive-latex-tools
-                                        texlive-latex-upquote
-                                        texlive-url
-                                        texlive-latex-xkeyval)))
-       ("tzdata" ,tzdata-for-tests)
-       ("xz" ,xz)))
+     (list bzip2
+           perl
+           pkg-config
+           texinfo                      ; for building HTML manuals
+           (texlive-updmap.cfg (list texlive-ae
+                                     texlive-inconsolata
+                                     texlive-fonts-ec
+                                     texlive-grfext
+                                     texlive-amsfonts
+                                     texlive-latex-base
+                                     texlive-latex-fancyvrb
+                                     texlive-latex-graphics
+                                     texlive-hyperref
+                                     texlive-oberdiek
+                                     texlive-latex-tools
+                                     texlive-latex-upquote
+                                     texlive-url
+                                     texlive-latex-xkeyval))
+           tzdata-for-tests
+           xz))
     (inputs
-     `(;; We need not only cairo here, but pango to ensure that tests for the
-       ;; "cairo" bitmapType plotting backend succeed.
-       ("pango" ,pango)
-       ("coreutils" ,coreutils)
-       ("curl" ,curl)
-       ("openblas" ,openblas)
-       ("gfortran" ,gfortran)
-       ("icu4c" ,icu4c)
-       ("libjpeg" ,libjpeg-turbo)
-       ("libpng" ,libpng)
-       ("libtiff" ,libtiff)
-       ("libxt" ,libxt)
-       ("pcre2" ,pcre2)
-       ("readline" ,readline)
-       ;; This avoids a reference to the ungraftable static bash.  R uses the
-       ;; detected shell for the "system" procedure.
-       ("bash" ,bash-minimal)
-       ("tcl" ,tcl)
-       ("tk" ,tk)
-       ("which" ,which)
-       ("zlib" ,zlib)))
+     (list coreutils
+           curl
+           openblas
+           gfortran
+           icu4c
+           libjpeg-turbo
+           libpng
+           libtiff
+           libxt
+           ;; We need not only cairo here, but pango to ensure that tests for the
+           ;; "cairo" bitmapType plotting backend succeed.
+           pango
+           pcre2
+           readline
+           tcl
+           tk
+           which
+           zlib
+           ;; This avoids a reference to the ungraftable static bash.  R uses the
+           ;; detected shell for the "system" procedure.
+           bash-minimal))
     (native-search-paths
      (list (search-path-specification
             (variable "R_LIBS_SITE")
@@ -452,8 +452,6 @@ available, greatly increasing its breadth and scope.")
                           "|"
                           (assoc-ref inputs "perl")
                           "|"
-                          (assoc-ref inputs "texlive")
-                          "|"
                           (assoc-ref inputs "texlive-bin")
                           "|"
                           (assoc-ref inputs "texinfo")